Ask Your Question
1

how is systemd automount configured

asked 2013-11-03 16:26:34 -0500

DJon gravatar image

I've read through the documentation for systemd automount, and there must be something missing.

I added noauto,x-systemd.automount to my NFS entries in /etc/fstab, but when I access the directory in Nautilus, nothing happens.

My understanding is that it should mount the export when the mount point is accessed. Is that correct?

The exports mount just fine using the mount command, or by selecting the side-pane entry in nautilus.

edit retag flag offensive close merge delete

Comments

Yes, that should work. What is the full line of your fstab entry?

mooninite gravatar imagemooninite ( 2013-11-05 09:59:28 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
2

answered 2014-07-17 16:46:21 -0500

zbyszek gravatar image

After adding the line to fstab you need to tell systemd about the change, by either

 systemctl daemon-reload

or by rebooting the machine.

edit flag offensive delete link more
0

answered 2014-07-18 23:03:06 -0500

abadrinath gravatar image

Add the entry to /etc/fstab, and it will work.

#
# /etc/fstab
# Created by anaconda on Mon Apr 14 19:56:10 2014
#
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
#
UUID=6b266543-a497-44de-981f-ee460b85590a /                       ext4    defaults        1 0
UUID=48ce0f9f-eee1-4f72-b90e-1a28e6a83c8e /boot                   ext4    defaults        1 0
UUID=D58E-1C9A          /boot/efi               vfat    umask=0077,shortname=winnt 0 0
UUID=448774a1-05f9-47e6-9fad-ac5ac4e10b64 /home                   ext4    defaults        1 0
UUID=a60856f9-2247-4d13-b4a8-a9e2ecd91aa4 /var                    ext4    defaults        1 0
UUID=0a0ff8de-5395-469d-8e51-a7982d4a3645 swap                    swap    defaults        0 0

Instead of noauto,x-systemd.automount, try `defaults in the third-last space.

HTH.

edit flag offensive delete link more
0

answered 2015-12-15 08:28:19 -0500

Reloading the system daemon didn't work for me. I needed to explicitly restart the remote-fs target.

systemctl restart remote-fs.target

Reboot the computer also works of course.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2013-11-03 16:26:34 -0500

Seen: 2,636 times

Last updated: Dec 15 '15