Ask Your Question
1

How can I disable abrt daemon to avoid 100% CPU usage?

asked 2013-11-02 17:03:18 -0600

alfC gravatar image

updated 2013-11-02 17:10:52 -0600

How can I disable abrt daemon to avoid 100% CPU usage? (Fedora 19)

Every hour I have a process called abrt-action-gen, taking 100% that never ends. Worst of all, it is a root process, so I have to sudo to kill and other users can't do anything about it.

edit retag flag offensive close merge delete

Comments

Checking, yum doesn't find any package that provides that process. Do you know where it came from?

sideburns gravatar imagesideburns ( 2013-11-02 23:31:05 -0600 )edit

@sideburns, I think it is abrt daemon, it is there in the default installation.

alfC gravatar imagealfC ( 2013-11-03 23:29:44 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
2

answered 2013-11-03 13:15:00 -0600

Marc lml gravatar image

You can disable a service with systemctl. This has to be executed as root.

systemctl disable abrtd.service
edit flag offensive delete link more
0

answered 2013-11-03 09:27:33 -0600

deusdara gravatar image

updated 2013-11-03 09:29:55 -0600

Hi

As root

$ su -

Password:(root password)

Run gnome-session-properties

And deselect the abrt GUI from starting with Gnome.

edit flag offensive delete link more

Comments

Why as root?

skytux gravatar imageskytux ( 2013-11-03 16:23:04 -0600 )edit

I cannot find anything with that name in the list given by gnome-session-properties, the lists run from Blueman Applet to xscreensaver but there is no abrt in between.

alfC gravatar imagealfC ( 2013-11-03 23:28:06 -0600 )edit

@alfC: Please, do it as normal user.

skytux gravatar imageskytux ( 2013-11-04 11:00:05 -0600 )edit

I tried both, as root and as normal user. I am trying for a few days Mark's solution.

alfC gravatar imagealfC ( 2013-11-04 14:08:07 -0600 )edit

Question Tools

Stats

Asked: 2013-11-02 17:03:18 -0600

Seen: 10,735 times

Last updated: Nov 03 '13