Ask Your Question
0

when adding a user from CL it does not appear in GUI every time why?

asked 2013-10-31 14:42:35 -0600

rxrking gravatar image

When entering a user from the root user in command line it does not show up in the GUI list as it should. I am using the command of adduser. Sometimes it pops up in the GUI other times it does not. Any suggestions as to why this happens. Also, we are using Fedora 19. This is a classroom lab project.

edit retag flag offensive close merge delete

Comments

The first thing I’d check is /etc/passwd. What does the line for the newly created user look like? (Don’t worry about the security of posting it; passwords are stored elsewhere these days.) Also, what arguments are you passing to adduser?

Gareth Jones gravatar imageGareth Jones ( 2013-11-01 11:04:10 -0600 )edit
1

If you add a new user, you must configure the password in order for it to appear in GDM. You can use the command passwd myuser in order to do it.

remjg gravatar imageremjg ( 2013-11-01 11:59:51 -0600 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2013-11-01 11:40:57 -0600

baptistemm gravatar image

updated 2013-11-01 11:41:56 -0600

An educated guess is that only users with an id contained within a certain range are considered as real users (read "humans") and so listed at graphical boot.

Compare the uid between the users and find those listed at boot, and create a users in the range of the users listed.

and don't forget tell here if it works.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-10-31 14:42:35 -0600

Seen: 133 times

Last updated: Nov 01 '13