Ask Your Question
0

Error Install Wine Fedora 19 (Bad Packages or something worse?)

asked 2013-10-30 19:32:30 -0600

Davess gravatar image

updated 2014-03-18 17:07:48 -0600

mether gravatar image

Hello! I've been loving fedora 19 so far but intstalling wine has been a nightmare. Here's the error output (It's long)

Error: Package: nss-sysinit-3.14.3-13.0.fc19.x86_64 (@koji-override-0/$releasever)
           Requires: nss = 3.14.3-13.0.fc19
           Removing: nss-3.14.3-13.0.fc19.x86_64 (@koji-override-0/$releasever)
               nss = 3.14.3-13.0.fc19
           Updated By: nss-3.15.2-2.fc19.x86_64 (updates-testing)
               nss = 3.15.2-2.fc19
           Removing: nss-3.15.2-1.fc19.x86_64 (installed)
               nss = 3.15.2-1.fc19
           Updated By: nss-3.15.2-2.fc19.x86_64 (updates-testing)
               nss = 3.15.2-2.fc19

Error: Package: glibc-common-2.17-4.fc19.x86_64 (@koji-override-0/$releasever)
           Requires: glibc = 2.17-4.fc19
           Removing: glibc-2.17-4.fc19.x86_64 (@koji-override-0/$releasever)
               glibc = 2.17-4.fc19
           Updated By: glibc-2.17-19.fc19.x86_64 (updates-testing)
               glibc = 2.17-19.fc19
           Removing: glibc-2.17-18.fc19.x86_64 (installed)
               glibc = 2.17-18.fc19
           Updated By: glibc-2.17-19.fc19.x86_64 (updates-testing)
               glibc = 2.17-19.fc19

Error: Package: p11-kit-trust-0.18.3-1.fc19.x86_64 (@koji-override-0/$releasever)
           Requires: p11-kit(x86-64) = 0.18.3-1.fc19
           Removing: p11-kit-0.18.3-1.fc19.x86_64 (@koji-override-0/$releasever)
               p11-kit(x86-64) = 0.18.3-1.fc19
           Updated By: p11-kit-0.18.7-1.fc19.x86_64 (updates-testing)
               p11-kit(x86-64) = 0.18.7-1.fc19
           Removing: p11-kit-0.18.5-1.fc19.x86_64 (installed)
               p11-kit(x86-64) = 0.18.5-1.fc19
           Updated By: p11-kit-0.18.7-1.fc19.x86_64 (updates-testing)
               p11-kit(x86-64) = 0.18.7-1.fc19

Error: Package: nss-tools-3.14.3-13.0.fc19.x86_64 (@koji-override-0/$releasever)
           Requires: nss(x86-64) = 3.14.3-13.0.fc19
           Removing: nss-3.14.3-13.0.fc19.x86_64 (@koji-override-0/$releasever)
               nss(x86-64) = 3.14.3-13.0.fc19
           Updated By: nss-3.15.2-2.fc19.x86_64 (updates-testing)
               nss(x86-64) = 3.15.2-2.fc19
           Removing: nss-3.15.2-1.fc19.x86_64 (installed)
               nss(x86-64) = 3.15.2-1.fc19
           Updated By: nss-3.15.2-2.fc19.x86_64 (updates-testing)
               nss(x86-64) = 3.15.2-2.fc19

 You could try using --skip-broken to work around the problem

** Found 266 pre-existing rpmdb problem(s), 'yum check' output follows:
LibRaw-0.14.8-3.fc19.20120830git98d925.x86_64 is a duplicate with LibRaw-0.14.8-2.fc19.x86_64
1:NetworkManager-0.9.8.2-9.git20130709.fc19.x86_64 is a duplicate with 1:NetworkManager-0.9.8.2-2.fc19.x86_64
1:NetworkManager-glib-0.9.8.2-9.git20130709.fc19.x86_64 is a duplicate with 1:NetworkManager-glib-0.9.8.2-2.fc19.x86_64
SDL-1.2.15-11.fc19.x86_64 is a duplicate with SDL-1.2.15-8.fc19.x86_64
abrt-2.1.8-1.fc19.x86_64 is a duplicate with abrt-2.1.5-1.fc19.x86_64
abrt-addon-ccpp-2.1.8-1.fc19.x86_64 is a duplicate with abrt-addon-ccpp-2.1.5-1.fc19.x86_64
abrt-addon-kerneloops-2.1.8-1.fc19.x86_64 is a duplicate with abrt-addon-kerneloops-2.1.5-1.fc19.x86_64
abrt-addon-vmcore-2.1.8-1.fc19.x86_64 is a duplicate with abrt-addon-vmcore-2.1.5-1.fc19.x86_64
abrt-addon-xorg-2.1.8-1.fc19.x86_64 is a duplicate with abrt-addon-xorg-2.1.5-1.fc19.x86_64
abrt-dbus-2.1.8-1.fc19.x86_64 is a duplicate with abrt-dbus-2.1.5-1.fc19.x86_64
abrt-libs-2.1.8-1.fc19.x86_64 is a duplicate with abrt-libs-2.1.5-1.fc19.x86_64
abrt-retrace-client-2.1.8-1.fc19.x86_64 is a duplicate with abrt-retrace-client-2.1.5-1.fc19.x86_64
adwaita-gtk2-theme-3.8.4-1.fc19.x86_64 ...
(more)
edit retag flag offensive close merge delete

Comments

You system is a bad state. Make backup. Then run yum clean all. Modify /etc/yum.repos.d/*.repo files to keep enabled only fedora and fedora-updates repositories (disable all other repositories). Then try to remove package duplicates (one by one) as described here http://docs.fedoraproject.org/en-US/Fedora/14/html/Software_Management_Guide/ch07s03.html

marcindulak gravatar imagemarcindulak ( 2013-10-31 08:32:22 -0600 )edit

Ok, I did everything described in the article and now have this: http://pastebin.com/khJmARNi

Davess gravatar imageDavess ( 2013-10-31 14:44:12 -0600 )edit

What command resulted in this error? Post also the output of: yum clean all; yum repolist

marcindulak gravatar imagemarcindulak ( 2013-11-01 04:15:33 -0600 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2013-11-02 12:31:39 -0600

Avik gravatar image

Hello... don't try to directly install wine... try by installing Playonlinux app.. it's depends on wine infact use many wine version in one app..don't panic at the installation time it'll install just one wine version you could modify it later.. try this steps:

su -c 'rpm -ivh http://rpm.playonlinux.com/playonlinux-yum-4-1.noarch.rpm' su -c 'yum install playonlinux' Optional …

This step might be optional, but if you use a 64-bit version of Fedora 18 and while trying to run ‘PlayOnLinux’ if you get an error saying that: ‘PlayOnLinux is unable to find 32bits OpenGL libraries …’, then that is probably because the 32-bit version of ‘Mesa library’ (a software library used for OpenGL, 3D rendering) is not installed.

su -c 'yum install mesa-dri-drivers mesa-dri-drivers.i686'

..easy or not?

edit flag offensive delete link more
0

answered 2013-11-06 19:35:22 -0600

anffdraco gravatar image

updated 2013-11-06 19:36:53 -0600

I'm still having this problem and have nothing to do but pull out more hair:

Package mesa-dri-drivers-9.2-1.20130919.fc19.x86_64 already installed and latest version Package mesa-dri-drivers-9.2-1.20130919.fc19.i686 already installed and latest version Nothing to do

Fedora 19x64, wine installed through play on linux, fresh install, have tried fresh installs with proprietary drivers, kmod drivers, and akmod drivers all arriving to the same problem.

What now?

edit flag offensive delete link more

Comments

This is a different question and it's very good you have created another thread for it https://ask.fedoraproject.org/question/35444/does-diablo-3-play-on-linux-work-on-64-bit-fedora-19/ . "... already installed and latest version" message says that your mesa-dri-drivers is up-to-date. Generally always try to use the packages from Fedora first - see randomuser's comment at https://ask.fedoraproject.org/question/35015/running-eclipse-in-fedora-19/ The installation of wine is described here https://ask.fedoraproject.org/question/7221/help-with-wine/

marcindulak gravatar imagemarcindulak ( 2013-11-11 08:12:59 -0600 )edit

My other thread has not gotten attention, your comment here in another thread is the first attention my thread has actually gotten despite bumping it twice. But, you didn't answer my question; you reworded what I already know: I've installed the packages for mesa-dri-drivers.

So... [Check_OpenGL] Warning: 32bits direct rendering is not enabled

(despite following your link to another comment for a somewhat related scenario where another game won't work because playonlinux doesn't see the libraries right. Why? since my thread is still not getting replies)

anffdraco gravatar imageanffdraco ( 2013-11-11 10:51:36 -0600 )edit

Question Tools

Stats

Asked: 2013-10-30 19:32:30 -0600

Seen: 974 times

Last updated: Nov 06 '13