Ask Your Question
0

Sudo gedit/focuswriter does not change input language?

asked 2013-10-28 05:58:21 -0600

Pablok gravatar image

updated 2014-09-12 19:46:31 -0600

mether gravatar image

Hi.
I've been struggling to directly save files in my fedora-19-live usb.
The method I found was to "sudo [program]" and work.
However, when I use this method to call, for example gedit, it does not change input language.
The keyboard input on the top bar shows that it changed correctly, byt my typing language Korean does not appear. It remains to be written in English.

This is the result if I do "sudo gedit".

(gedit:2122): Gtk-WARNING *: Calling Inhibit failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

and if I su -> password -> # gedit,

(gedit:2359): dconf-WARNING *
: failed to commit changes to dconf: 연결이 닫혔습니다
Error creating proxy: 연결이 닫혔습니다 (g-io-error-quark, 18)
Error creating proxy: 연결이 닫혔습니다 (g-io-error-quark, 18)
Error creating proxy: 연결이 닫혔습니다 (g-io-error-quark, 18)
Error creating proxy: 연결이 닫혔습니다 (g-io-error-quark, 18)
Error creating proxy: 연결이 닫혔습니다 (g-io-error-quark, 18)
(gedit:2359): Gtk-CRITICAL **: gtk_application_inhibit: assertion `application->priv->sm_proxy != NULL' failed

"연결이 닫혔습니다" means "connection is closed."

if I do the same process with Focuswriter:

Qt: Session management error: None of the authentication protocols specified are supported

When opening a file, it shoots the "Error creating proxy...".
There are times when it is possible to type in Korean letters, but it is rare, sudden cases. I've tested with other languages, but Russian or Greek seems to work with no problem, and just Korean or some Asian inputs have problems.
Please save me from this problem. I really don't want to end up using MS Windows again. :(
Sorry for my lousy English; it's not my mothertongue.


Pablo

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2018-12-18 03:48:55 -0600

Language System

Language settings and usage are very tricky, and if language settings are required, the workstations are easy to set up, while the server settings are set using the default settings, so you'll need to install a lot of the necessary libraries and programs .

However, considering the usage and usability of Hangul, there are many parts that need to be carefully checked in order to apply well in fedora system. In particular, ibus, fonts, and Korean libraries must be installed, and the glibc library and related programs are required to support them.

* Reference Hangul Set
https://ask.fedoraproject.org/en/question/110978/korean-char-combined-in-one-size/

If this problem applies to all non-English languages, it is linked to the keyboard and language settings. by default, local settings must be applied correctly.

I will continue to answer questions about the Hangul and language settings, so I will continue to support Fedora Users.

Fedora29 Server KDE System, written by simmon

edit flag offensive delete link more
0

answered 2013-10-28 12:56:10 -0600

Persi gravatar image

I'm not sure about this but my best guess is that it's caused by running gedit as root. I'm speculating here but I'd say that the input widget only changes the input for your user and not root, which is the user that's running gedit.

If for any reason you can't install fedora directly on your hard drive to test this, I'd suggest you try it out on a VM such as virtualbox.

I realize this is not very helpful but it's the best I can think of.

edit flag offensive delete link more

Comments

Languages other than Korean works fine... and strangely, Focuswriter started to work as I expected. The main reason was to use the program, so I may say it's solved...? Still, I'll try in VM and post the results. Thank you for your answer.

Pablok gravatar imagePablok ( 2013-11-09 12:24:44 -0600 )edit

Question Tools

Stats

Asked: 2013-10-28 05:58:21 -0600

Seen: 781 times

Last updated: Dec 18 '18