Ask Your Question
0

Fedora 19 doesn't detect wireless card on lenovo yoga 13

asked 2013-10-25 14:12:41 -0600

mfdo11 gravatar image

updated 2013-10-25 14:31:58 -0600

Fedora 19 is no detecting the wireless card on Lenovo Yoga 13. How can I fix it?

edit retag flag offensive close merge delete

Comments

First try: lspci | grep -i wireless

wintermute gravatar imagewintermute ( 2013-10-25 23:42:24 -0600 )edit

Have you installed all the necessary packages? Like kmod-wl from the RPMFusion repository.

remjg gravatar imageremjg ( 2013-10-27 06:09:52 -0600 )edit

As wintermute said, make sure the card is detected. It is probably detected, but doesn't have a driver. Follow this link to get the wifi going if the card is detected: http://askubuntu.com/questions/318608/lenovo-yoga-13-realtek-wireless-driver

abadrinath gravatar imageabadrinath ( 2014-06-15 04:43:49 -0600 )edit

3 Answers

Sort by ยป oldest newest most voted
1

answered 2014-06-14 13:29:25 -0600

sebgod gravatar image

On a Yoga 13, using Fedora 20 x64, with Kernel versions 3.13-3.14, I was very successful with:

git clone https://github.com/lwfinger/rtl8723au
cd rtl8723au
make
sudo make install
sudo reboot
edit flag offensive delete link more

Comments

+1 That is the correct driver. :)

abadrinath gravatar imageabadrinath ( 2014-06-15 04:45:11 -0600 )edit

I've to add, now that there is 3.15.x in production, this hack is not necessary any longer. It works now OOTB, and with much less tainted kernel errors :)

sebgod gravatar imagesebgod ( 2014-08-17 05:45:34 -0600 )edit

Ok, thanks for the confirmation!

abadrinath gravatar imageabadrinath ( 2014-08-17 05:46:41 -0600 )edit

@sebgod would you know why it does not work on the yoga 11s kernel 3.15.10-201?

John D Giotta gravatar imageJohn D Giotta ( 2014-09-09 17:44:03 -0600 )edit

Huh, probably an internal kernel thing. Best thing is to submit a bug. NOT safe to mess around with de kernel unless you're an expert-at-messing-things-up like me. :P

abadrinath gravatar imageabadrinath ( 2014-09-10 01:15:52 -0600 )edit
1

answered 2014-04-14 23:36:05 -0600

nmvega gravatar image

updated 2014-04-15 00:46:54 -0600

remjg gravatar image

Try this:

sudo modprobe -r ideapad_laptop

And should that work for you, you can make it permanent by doing this:

sudo echo "blacklist ideapad_laptop" > /etc/modprobe.d/ideapad_wlan-blacklist.conf

Then reboot.

edit flag offensive delete link more
0

answered 2013-10-26 01:22:39 -0600

yanglifu90 gravatar image

Go to http://wireless.kernel.org/en/users and download a driver for the wireless card.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-10-25 14:12:41 -0600

Seen: 1,704 times

Last updated: Jun 14 '14