Ask Your Question
0

Drivers [applets?] needed to use USB-connected HP copier with Fedora 19 KDE

asked 2013-10-21 21:26:08 -0600

hawkfeather gravatar image

updated 2014-09-29 23:21:17 -0600

mether gravatar image

I recently got a Hewlett-Packard Photosmart c7200 model copier\scanner\fax\etc., and while it's recognized without difficulty by both Kubuntu 12.04 and Manjaro KDE, Fedora 19 KDE refuses to acknowledge its presence, at least when it's connected by USB. I haven't tried it by Ethernet or wireless yet. At any rate, my theory is that the necessary drivers and\or applets aren't present. If I'm right, could someone point me to where to get the required software [the SANE website has been no help], or if I'm wrong, enlighten me as to what the situation is? Cheers.

The following is the output from lsusb -vv:

lsusb -vv | grep -i 'tt-pa'
Bus 007 Device 002: ID 03f0:6511 Hewlett-Packard PhotoSmart C7200 series
  idVendor           0x03f0 Hewlett-Packard
Couldn't open device, some information will be missing
Couldn't open device, some information will be missing
Couldn't open device, some information will be missing
Couldn't open device, some information will be missing
Couldn't open device, some information will be missing
Couldn't open device, some information will be missing
Couldn't open device, some information will be missing
Couldn't open device, some information will be missing
Couldn't open device, some information will be missing
Couldn't open device, some information will be missing
Couldn't open device, some information will be missing
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-10-22 03:42:16 -0600

Amit Caleechurn gravatar image

You need to install the HPLIP packages to enable the supported features as per http://hplipopensource.com/hplip-web/models/photosmart/photosmart_c7200_series.html

yum install hplip hplip-gui

You should now have an HP icon in your menu to configure the device.

edit flag offensive delete link more

Comments

Thanx much. hplip was already on my system, and it turned out that an lp group needed to be created, and some dependencies needed to be installed or upgraded.

hawkfeather gravatar imagehawkfeather ( 2013-10-23 21:42:49 -0600 )edit

Question Tools

Stats

Asked: 2013-10-21 21:26:08 -0600

Seen: 218 times

Last updated: Oct 22 '13