Ask Your Question
0

Black terminal

asked 2013-10-20 10:51:17 -0600

Magnus gravatar image

updated 2014-04-11 16:50:59 -0600

remjg gravatar image

Hi I recently installed Fedora 18 on my laptop. when i wanted to use the terminal to install flash i realized that i couldn't see anything of what I was typing in the terminal. First i thought that the fonts was black against a black background. But in the preferences it is stated that should be white txt against black background. Any one have a suggestion what is causing this?

Regards Magnus

edit retag flag offensive close merge delete

Comments

Do you use some proprietary video driver? Can you see "anything" if you go to tty2 (alt+ctrl+f2) ?

casep gravatar imagecasep ( 2013-10-20 15:56:44 -0600 )edit

What terminal are you using? What DE? Please, give us more info!! :)

skytux gravatar imageskytux ( 2013-10-20 15:56:57 -0600 )edit

sometimes a terminal window can get confused; I've done it when accidentally running cat on a binary file, for example. Even if you can't see the output, you might be able to fix it by pressing Ctl+c a few times to exit any running utilities, then running the command reset and pressing enter. If that doesn't work, you will probably have to open a new terminal window.

randomuser gravatar imagerandomuser ( 2013-10-20 19:40:55 -0600 )edit

Hi, yes (alt+ctrl+f2) works, how ever when trying to start the DE(gnome-session) it fails to launch (don't know if this is related to the problem at hand). btw I'm using fedora 19, not 18 as I stated before. I'm also running gnome DE and the default gnome-terminal 3.8.2. If type gedit in the terminal Gedit launches, so it is clear that terminal is working accept I cant see what I'm typing which could be a problem in the long run ;-)

Magnus gravatar imageMagnus ( 2013-10-21 12:01:45 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2013-10-21 12:45:21 -0600

Magnus gravatar image

I solved the problem. I opened the terminal then opened edit-> Profile Preferences then opened the Colors tab and disabled the option Use colors from system theme. This solved the problem. A bug?

Thanks for all the suggestions. /Magnus

edit flag offensive delete link more
0

answered 2013-10-20 18:19:50 -0600

I am running Fedora 19 and I recently downloaded flash and everything is working fine. If you can elaborate more on what exactly you are typing in the terminal, maybe I can cross check that...

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2013-10-20 10:51:17 -0600

Seen: 2,165 times

Last updated: Oct 21 '13