Ask Your Question
3

Gnome 3 GDM login using keyboard only? [closed]

asked 2013-10-18 14:55:04 -0600

cobra gravatar image

Here's the scenario with the pretty GDM/Gnome 3 login screen that comes with Fedora 18, 19, etc.

When I've been using my computer for a bit I log out and turn off the monitor. When I return, often hours later, I'm presented with the 'screensaver' over the GDM login screen. I hit ESC to lift the screensaver and be presented with the GDM login with a list of users that I could select to log in with.

Now I have to switch to the mouse and click on the name I want to log in as, or hit 'not listed' to type a new name. Now, I'm a power-user, so I don't want to use the mouse unless I absolutely have to. But GDM enforces it here - I have to click, which is an inconvenience.

Unless someone has borrowed my mouse, in which case I have no way to log-in at all...

There must be a keyboard short-cut to select a user, or at least to flip focus to the user list that I can navigate with the cursor keys and Enter? For the life of me I can't find one.

Does anyone know how to do this? Or is this just another shortcoming of the new, whizzy Gnome UI?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by zoltanh721
close date 2014-07-04 22:20:03.577623

Comments

1

I noticed the same problem (it also happens when you log off) and I don't think it is possible. From a superficial view it seems that the GDM user list widget doesn't get the input focus and so all keyboard events go somewhere else.

Felix Schwarz gravatar imageFelix Schwarz ( 2013-10-21 07:10:49 -0600 )edit
1

It only seems to be when the screensaver has dropped over the login page. If you log off, you can log on again immediately by pressing 'Enter'. I don't know what happens if you have multiple users listed.

cobra gravatar imagecobra ( 2013-10-21 07:29:41 -0600 )edit
2

Does Ctrl+Alt+Tab help?

Gareth Jones gravatar imageGareth Jones ( 2013-10-21 07:32:51 -0600 )edit
1

Hmm, not really an 'obvious' shortcut... It's a bit finger-achingly difficult, almost the sort of shortcut that Microsoft would have thought up (alongside their tortuous CTRL-F4 to close the current document which is CTRL-W here in the world of common-sense). I'll give it a go when I'm back on my Fedora rig later on. Unless someone else wants to give it a try in the meantime. Thanks for the suggestion.

cobra gravatar imagecobra ( 2013-10-21 07:36:53 -0600 )edit
2

It’s the default “short-cut” for switching keyboard focus between elements of GNOME Shell, which is used by GDM, so I guess it should work.

Gareth Jones gravatar imageGareth Jones ( 2013-10-21 08:28:25 -0600 )edit

2 Answers

Sort by » oldest newest most voted
4

answered 2014-06-14 12:53:16 -0600

patrickmclaren gravatar image

updated 2014-07-01 11:24:06 -0600

This is simply a combination of the answer by Jha Naman and the comment by Garreth Jones. It works for me, even helps get around an issue that Synergy has with displaying the cursor on the GDM login screen of a remote machine! Awesome! You'll need to use the following:

  1. CTRL+ALT+TAB, then
  2. SPACE or ENTER

In my case, there is only one login user displayed. When I press either SPACE or ENTER, it proceeds the password entry fields. I can't be sure what the behavior is, when more than one user is displayed.

edit flag offensive delete link more

Comments

1

As has already been established, pressing space or pressing enter does not work. Read my original question - the problem never arises when the login screen first appearsd, only after the 'screensaver' screen appeared. This is brain-dead approach taken by GDM that spoils this login page for everyone. Requiring the use of CTRL-ALT-TAB (an unguessable key combination) means that casual users cannot log in without knowledge of how Gnome works, this is a bad paradigm.

cobra gravatar imagecobra ( 2014-06-16 03:42:40 -0600 )edit
1

Employing CTRL+ALT+TAB, then SPACE or ENTERdoes solve the issue after the screensaver has been displayed. You originally stated "[t]here must be a keyboard short-cut to select a user, or at least to flip focus to the user list that I can navigate with the cursor keys and Enter? For the life of me I can't find one." As far as I can see, this question has been resolved.

patrickmclaren gravatar imagepatrickmclaren ( 2014-06-30 16:30:56 -0600 )edit
1

Yes, the question was resolved, but SPACE or ENTER did not resolve it. Others suggested that and it didn't work, still (as far as I know) doesn't work. There is still no formal answer to this, btw., so I cannot accept the 'correct' solution. If your answer suggests that the solution is BOTH the things you suggest, then you're correct. If you're proposing a list of solution (as the text around this appears to read) then you're wrong. I'd like to see an answer to this that makes this obvious for people who can't guess the keys themselves.

cobra gravatar imagecobra ( 2014-07-01 03:30:45 -0600 )edit

I found that Ctrl+Alt+Tab (to select the login window) and then Tab (to cycle between the listed users) worked for me. (Fedora 19 x86-64, up-to-date.) Does this work for the OP?

tkil gravatar imagetkil ( 2014-09-17 02:11:03 -0600 )edit
-2

answered 2013-10-19 06:00:47 -0600

Pressing either the space bar key or Enter key should do the trick. Try it.

edit flag offensive delete link more

Comments

Nope, that doesn't work. Did you try this? It's possible to do this on boot-up, but it doesn't work if the computer is already on.

cobra gravatar imagecobra ( 2013-10-19 16:07:59 -0600 )edit

yes it does seem to work. Though i am using gnome 3.10 on F20 alpha which could account for differences.

Jha Naman gravatar imageJha Naman ( 2013-10-24 08:30:31 -0600 )edit

No it does not work if the screen saver had activated. And that is the problem!!!

antofthy gravatar imageantofthy ( 2014-03-20 18:14:11 -0600 )edit

Question Tools

3 followers

Stats

Asked: 2013-10-18 14:55:04 -0600

Seen: 2,470 times

Last updated: Jul 01 '14