Ask Your Question
0

bbswitch not turning discrete graphics off

asked 2013-10-16 06:09:39 -0600

Bharat gravatar image

updated 2014-04-11 16:22:19 -0600

remjg gravatar image

Due to some problems, I had to reinstall fedora. I currently have fedora-19 with kernel version 3.11.4-201.

I haven't installed NVIDIA drivers and am using the default nouveau drivers for graphics. Bumblebee and bbswitch got installed properly but bbswitch fails to turn off discrete graphics. I did tee /proc/acpi/bbswitch<<<OFF but when I check the status it reports it on. dmesg|grep bbswitch gives this:

[   25.192983] bbswitch: module verification failed: signature and/or required key missing - tainting kernel
[   25.193158] bbswitch: version 0.7
[   25.193165] bbswitch: Found integrated VGA device 0000:00:02.0: \_SB_.PCI0.GFX0
[   25.193172] bbswitch: Found discrete VGA device 0000:01:00.0: \_SB_.PCI0.PEG0.PEGP
[   25.193316] bbswitch: detected an Optimus _DSM function
[   25.193325] bbswitch: Succesfully loaded. Discrete card 0000:01:00.0 is on
[ 1383.773601] bbswitch: device 0000:01:00.0 is in use by driver 'nouveau', refusing OFF

Bumblebee-daemon is running but optirun glxgears -info gives this:

[ 2441.794492] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) Failed to load module "mouse" (module does not exist, 0)

[ 2441.794545] [ERROR]Aborting because fallback start is disabled.

I created:

  • bbswitch.conf in /etc/modprobe.d/ with bbswitch load_state=0 in it.
  • bbswitch.conf in /etc/modules-load.d/ with bbswitch in it.
  • nouveau.conf in /etc/modprobe.d/ with

    blacklist nouveau

    blacklist nvidia

renamed nouveau.conf to blacklist.conf but no difference.

How do I switch off the discrete graphics card ? It happened quite smoothly in my previous fedora-17 which I fedupped to fedora-19. Isn't bumblebeed supposed to turn it off without manual intervention? How do I know if bbswitch is compatible with the kernel?

EDIT

During one boot the graphics was turned off but it turned on again when i tried optirun glxgears -info (which btw gave the same error). I reinstalled bbswitch and bumblebee but it doesnt solve the issue.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-10-16 08:13:43 -0600

Bharat gravatar image

updating initrd with dracut --force solved the problem.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-10-16 06:09:39 -0600

Seen: 3,238 times

Last updated: Oct 16 '13