Ask Your Question
0

Fedora 19 two finger touchpad scrolling, works on Gnome desktop but not Cinnamon?

asked 2013-10-02 15:11:23 -0600

oznah gravatar image

I am having problems with two finger touchpad scrolling on Cinnamon deskop in Fedora 19. This is a fresh install on a Lenovo Thinkpad X1 Carbon. The touchpad works for mouse movement, but it does not work for scrolling. I tried scrolling in terminal & Firefox, but neither work.

I did look at "mouse & touchpad" settings Preferences. The checkbox is checked for two finger scrolling. The Preferences settings seem to have no affect on the touchpad at all.

Thanks for the help.

edit retag flag offensive close merge delete

Comments

Artur, I tried your suggestion. That did not work.

oznah gravatar imageoznah ( 2013-10-03 09:34:35 -0600 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2013-10-03 02:11:54 -0600

none gravatar image

updated 2013-10-08 03:40:05 -0600

Create file: /etc/X11/xorg.conf.d/10-synaptics.conf:

Section "InputClass"
       Identifier "touchpad catchall"
       Driver "synaptics"
       MatchIsTouchpad "on"
       MatchDevicePath "/dev/input/event*"
       Option "TapButton1" "1"
       Option "TapButton2" "3"
       Option "TapButton3" "2"
       Option "VertTwoFingerScroll" "1"
       Option "HorizTwoFingerScroll" "1"
EndSection

Restart system, and try.

EDIT: As I migrated from LXDE (where above worked fine) to Cinnamon, I noticed, that Cinnamon ignore above configuration, and require to be setup be: System Settings/Mouse and Touchpad, here in tab Touchpad you can turn on touchpad and related options (works for me).

edit flag offensive delete link more
0

answered 2013-10-03 14:41:32 -0600

oznah gravatar image

I am not sure why this is required under Cinnamon but not Gnome, but I found the solution.

1. Install gpointing-device-settings

> sudo yum install gpointing-device-settings

2. Run gpointing-device-settings

> gpointing-device-settings

3. Select the “Scrolling” tab.

4. Check all that apply

edit flag offensive delete link more

Comments

These settings don't persist after a reboot. Looking for another solution.

oznah gravatar imageoznah ( 2013-10-09 12:04:02 -0600 )edit

Installing dconf-editor seems to do the trick. Go to org/cinnamon/settings-daemon/peripherals/touchpad and change the settings you need. http://askubuntu.com/questions/64334/gpointing-device-settings-lost-on-reboot

oznah gravatar imageoznah ( 2013-10-09 12:05:47 -0600 )edit

Question Tools

Stats

Asked: 2013-10-02 15:11:23 -0600

Seen: 3,779 times

Last updated: Oct 08 '13