Ask Your Question
0

Dual Boot Fedora 19 with Windows 8 Issue

asked 2013-09-25 16:55:36 -0500

AndyWM gravatar image

updated 2013-09-27 00:18:45 -0500

FranciscoD_ gravatar image

Hello,

I recently tried to install Fedora 19 on my Acer laptop with the intention of retaining windows 8. I got to the install to HDD stage. I chose to shrink the 'Acer' partition to accommodate the Fedora partitions. It booted into fedora fine; but there is no evidence of the Windows boot option. Looking at the break down of the disk. All the original partitions look like they are still there.

Anything I can do here?

For the linux partition I selected LVM as it was the default option. There are 8 partitions on the disk.

p1: Microsoft Windows Recovery Environment (System) 419mb NTFS – Not Mounted

p2: EFI System 315mb FAT (32 bit) – Not Mounted

p3: Microsoft Reserved 134mb unknown

p4: Basic Data 463gb NTFS – Not Mounted

p5: BIOS Boot 1mb unknown

p6: Basic Data 524mb Ext4

p7: Linux LVM 15gb LVM2 Physical Volume (LVM2 001)

p8: Microsoft Windows Recovery Environment (System) 20gb NTFS – Not Mounted

edit retag flag offensive close merge delete

Comments

i instal window and fedora on system and now fedora is running option to run window is not looking how option cameee???????????

kashif gravatar imagekashif ( 2014-03-31 06:54:52 -0500 )edit

2 Answers

Sort by » oldest newest most voted
2

answered 2013-09-26 07:51:56 -0500

jsedlak gravatar image

Try to recreate grub configuriation. Just ensure you have efi grub installed (probably you have) with:

yum install grub2-efi shim

and then recreate configuration with:

grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg
edit flag offensive delete link more

Comments

He'll probably need to mount the windows partitions first for grub to detect windows.

FranciscoD_ gravatar imageFranciscoD_ ( 2014-03-31 07:29:45 -0500 )edit
FranciscoD_ gravatar imageFranciscoD_ ( 2014-03-31 07:30:19 -0500 )edit

From the OP:

p5: BIOS Boot 1mb unknown

that probably means the Fedora installer wasn't booted in UEFI mode and it performed a BIOS installation on a GPT-labelled HDD, and so it created a BIOS boot partition for GRUB2 to work.

So a clean install and ensuring that the media is booted in UEFI mode (e.g. by disabling Legacy/CSM mode in the firmware settings).

IIUC when booting the installation media you may see two entries for it, one for regular BIOS boot and one for UEFI; to boot in UEFI mode select the boot entry name prefixed with "UEFI: " in the UEFI boot manager.

Ahmad Samir gravatar imageAhmad Samir ( 2014-03-31 10:39:59 -0500 )edit

I think GRUB2 doesn't need the other OS's partition(s) to be mounted to detect them.

Especially so in UEFI systems, since it detects the windows bootmgfw.efi file on the EFI system partition.

I've tested running grub2-mkconfig and it detected another/separate Fedora installation and the windows installation on this machine without the partitions being mounted.

Ahmad Samir gravatar imageAhmad Samir ( 2014-03-31 10:46:18 -0500 )edit
0

answered 2013-09-27 19:42:20 -0500

Try F12 on boot up to get to boot menu

edit flag offensive delete link more

Comments

i try this but nothing i install window again but only fedora is running ?

kashif gravatar imagekashif ( 2014-03-31 06:56:40 -0500 )edit

Question Tools

Stats

Asked: 2013-09-25 16:55:36 -0500

Seen: 2,037 times

Last updated: Mar 31 '14