Ask Your Question
0

Couldn't update ICEauthority file /usr/share/jetty/.ICEauthority

asked 2013-08-31 01:51:51 -0600

littlep gravatar image

updated 2013-08-31 23:59:29 -0600

FranciscoD_ gravatar image

I'm using fedora17, I some how clicked 'jetty' automatic login ON. And now, every time I boot the system it gives me this message.. "Couldn't update ICEauthority file /usr/share/jetty/.ICEauthority". ... with a Logout option... But, the cursor is constantly "loading" and nothing happens for a long time.

And I have to do a force shutdown. Please help to solve this problem.

Thankx...

edit retag flag offensive close merge delete

Comments

Hello, it seems to me weird your ICEauthority file is store /usr/share/jetty/. Is jetty your username on your computer, so it seems you improperly configured it and set your $HOME directory as /usr/share/jetty. Could you confirm my tell ?

baptistemm gravatar imagebaptistemm ( 2013-08-31 11:22:56 -0600 )edit

I think it (jetty) is a default username because I created only one user i.e., 'admin'. And jetty was already there in ' other accounts ' .

littlep gravatar imagelittlep ( 2013-08-31 11:47:27 -0600 )edit

i did 'grep jetty /etc/passwd | cut -d: -f 3' , and thank you soooo..... much ,it worked!!! Thankx!

littlep gravatar imagelittlep ( 2013-09-02 08:55:45 -0600 )edit

Nice if I was able to solve your problem. I guess this is a bug that the jetty user is reported as a normal user. Could you do it ? What is the uid of the jetty user by the way ?

baptistemm gravatar imagebaptistemm ( 2013-09-02 08:58:52 -0600 )edit

it was 994

littlep gravatar imagelittlep ( 2013-09-02 09:01:00 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-08-31 12:58:35 -0600

baptistemm gravatar image

updated 2013-08-31 14:25:20 -0600

I guess I figure out what is your problem, you set autologin active for a application user. I don't understand though how jetty user was listed in the User settings.

Important note: you shouldn't use this user for a graphical session, it is not intended for that.

To solve the problem, open a terminal (press Ctrl+Alt+F2 at the same time, and login with your normal user)

First I need to know the user id of the user jetty

gdbus call --system --dest org.freedesktop.Accounts --object-path /org/freedesktop/Accounts --method org.freedesktop.Accounts.FindUserByName 'jetty'

or

grep jetty /etc/passwd | cut -d: -f 3

Then, we can disable autologin

gdbus call --system --dest org.freedesktop.Accounts --object-path /org/freedesktop/Accounts/UserXXXX --method org.freedesktop.Accounts.User.SetAutomaticLogin 'false'

Where XXXX is the uid of jetty user.

it should be good then if I properly understood your problem.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-08-31 01:51:51 -0600

Seen: 138 times

Last updated: Aug 31 '13