Ask Your Question
1

System hangs up on hibernate or reboot

asked 2013-08-29 09:20:17 -0600

Krish gravatar image

updated 2013-08-30 21:18:46 -0600

FranciscoD_ gravatar image

Installed fedora 19 on a dell laptop. Everything works fine, except system cannot hibernate or restart. It just hangs up.

edit retag flag offensive close merge delete

Comments

does it hang on the "shutting down" part, or on the "booting up" part?

Jann5s gravatar imageJann5s ( 2013-08-29 09:49:22 -0600 )edit

Do you have any error reported in the log files, you can find them under /var/log/ or with the command journalctl -b

baptistemm gravatar imagebaptistemm ( 2013-08-29 09:57:44 -0600 )edit

No error reported in log files. When I restart the system, it just shows the log from the time that session started.

Krish gravatar imageKrish ( 2013-08-30 15:39:52 -0600 )edit

I am using the KDE desktop. It has four options: sleep, hibernate, shut down, and restart. Sleep and shut down buttons work fine. When I press restart, the messages the system gives are:

Krish gravatar imageKrish ( 2013-08-30 15:41:04 -0600 )edit

[119.656372] mei_me 0000:00:16:0: Stop

Krish gravatar imageKrish ( 2013-08-30 15:41:47 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2013-08-30 21:17:50 -0600

FranciscoD_ gravatar image

From your last error message, it looks like a mei module issue. The kernel team is tracking known issues with the mei kernel modules. Please follow the bug below. They do have a few work arounds too.

This is not fedora specific. It's a regression introduced by mei upstream who are aware of it and are working on a fix already, as you'll understand from the comments in the bug report.

https://bugzilla.redhat.com/show_bug.cgi?id=917081

(As a rule, it's good to search bugzilla when you run into a new issue. The chances are that someone already ran into it and was kind enough to file a bug. If a bug isn't filed already, you should go ahead and do it.)

edit flag offensive delete link more
0

answered 2013-08-29 21:07:27 -0600

DmitryZayats gravatar image

updated 2013-08-29 21:11:05 -0600

Try changing BIOS settings. There should be something like

SATA Mode

And you need to change it to AHCI.

At least that worked for my Dell D630.

edit flag offensive delete link more

Comments

Did not work for me. I am installing on dell latitude e6220

Krish gravatar imageKrish ( 2013-08-30 15:37:25 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2013-08-29 09:20:17 -0600

Seen: 1,388 times

Last updated: Aug 30 '13