Ask Your Question
0

How do I enable Gnome Classic in Fedora 18?

asked 2013-08-17 11:05:53 -0600

viajeramental gravatar image

updated 2013-08-17 12:24:15 -0600

FranciscoD_ gravatar image

Hi everybody! I have a Fedora 18 in my netbook and I want to use it with Gnome Classic. I'd tried installing "gnome-classic-sesion" but it didn't work. Is there a way to have Gnome Classic on Fedora 18?

Thanks in advance!

edit retag flag offensive close merge delete

Comments

Duplicate of https://ask.fedoraproject.org/question/28958/how-do-i-enable-gnome-38-classic-mode-on-fedora-19/ Please search the forum before posting. Thanks :)

FranciscoD_ gravatar imageFranciscoD_ ( 2013-08-17 12:22:32 -0600 )edit
1

This is not a duplicate question, "gnome-classic-session" is only avaible for Fedora 19.

davidva gravatar imagedavidva ( 2013-08-17 13:47:56 -0600 )edit
1

There are workarounds that will let you backport gnome-classic-session to F18, but do you really need to do that? If you really want gnome-classic-session, is there a strong reason you don't want to upgrade to F19 with Gnome 3.8 where it is officially supported?

faustus gravatar imagefaustus ( 2013-08-17 15:59:31 -0600 )edit

My strong reason is that right now, I can't update or install a new OS. But Gnome and KDE become too slowly. I just want a desktop like in Trisquel. Thanks!

viajeramental gravatar imageviajeramental ( 2013-08-17 16:18:07 -0600 )edit

Aha! I didn't realize that 3.6 didn't have a classic session. Apologies. In that case, you can't get the classic session from a package as in 3.8.

FranciscoD_ gravatar imageFranciscoD_ ( 2013-08-17 20:28:05 -0600 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2013-08-17 18:36:12 -0600

hmaarrfk gravatar image

Gnome Classic Mode is basically a collection of extensions made to change the look and feel of gnome shell to make it "look" more traditional. After you install Gnome Classic Session, you can actually enable most (all??? never really tried) extensions without being in a Gnome Classic Session.

I do not think that it is meant to enable running Gnome on slower computers. You may want to dry a different DE.

LXDE, XFCE are more the mature choices in terms of light weight DE, there are even Fedora Spins that have those pre-installed

http://spins.fedoraproject.org/

edit flag offensive delete link more
0

answered 2013-08-18 11:36:28 -0600

deusdara gravatar image

updated 2013-08-18 11:37:49 -0600

Hi

Step One Open Terminal and type the following:

yum install dconf-editor

Step Two After the install is complete. Type the following

dconf-editor

Inside dconf-editor navigate to “org > gnome > desktop > session“. View the screenshot.  

Gnome Classic on Fedora 18 dconf editor

Step Three

Change the session-name to gnome-fallback

Set session name to Gnome Fallback   You have successfully Setup Gnome Classic on Fedora 18. Now logout of Fedora 18 and then log back in and you should have Gnome Classic on Fedora 18. To revert it back to Gnome 3 default just change the session-name back to gnome.

Note: If you can not change the session-name from your account then first login as root and change the session name and then login to your account and then you will be able to make the changes. Its weird I know but it did happen to me.

edit flag offensive delete link more

Comments

The above recipe of @deusdara worked perfectly for me.

demih gravatar imagedemih ( 2017-12-13 07:01:09 -0600 )edit

Question Tools

Stats

Asked: 2013-08-17 11:05:53 -0600

Seen: 5,698 times

Last updated: Aug 18 '13