Fedora 19 won't respect dual monitor order after boot

asked 2013-08-16 08:11:52 -0600

mtrojahn gravatar image

updated 2013-08-16 08:41:43 -0600

FranciscoD_ gravatar image

Hello,

After I upgraded to Fedora 19 (fedup method) my Xorg won't set dual monitors on the order I want... Bellow is my xorg.conf created by nvidia-settings.

If I use nvidia-settings to create that configuration and "apply" it using the tool, the monitor order is set on-the-fly correctly... But the change won't persist after a reboot... The Option "nvidiaXineramaInfoOrder" "DFP-1" is ignored for some reason I don't know...

Section "ServerLayout"
    Identifier     "Default Layout"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Samsung SA300/SA350"
    HorizSync       30.0 - 81.0
    VertRefresh     56.0 - 75.0
EndSection

Section "Device"
    Identifier     "Videocard0"
    Driver         "nvidia"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GT 440"
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "Videocard0"
    Monitor        "Monitor0"
EndSection

Section "Screen"

# Removed Option "metamodes" "DFP-0: 1366x768 +1920+312, DFP-1: 1920x1080 +0+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-1"
    Option         "metamodes" "DFP-0: nvidia-auto-select +1920+312, DFP-1: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
edit retag flag offensive close merge delete

Comments

does it work as expected if you use the nouveau drivers included in fedora rather than the nvidia binaries?

ryanlerch gravatar imageryanlerch ( 2013-08-16 09:23:52 -0600 )edit

Yes it does with a few graphic glitches when I hover the mouse over the "Application" menu on the top, reason why I was using Nvidia drivers on F18 release... I can live with those glitches but I rather not :)

mtrojahn gravatar imagemtrojahn ( 2013-08-17 09:56:24 -0600 )edit