Ask Your Question
0

Fedora's firewall is slowing networking with the Realtek RTL8187.

asked 2013-08-09 17:04:50 -0600

ultrasonicmadness gravatar image

Hello Ask Fedora!

I recently switched from Windows XP to Fedora 19 KDE Spin and I am really liking it. The only problem I am having is with (wireless) networking:

When I boot up into Fedora, the networking speed was what I would normally expect from Windows, but after about an hour, it would slow to the point of being unusable and I have to reboot Fedora to fix this. I also cannot host a Minecraft server at all (I can only log in from my computer; if others try to connect, they get a Can't reach server error).

I have tried getting a different adapter (ASUS USB-N13), which only made the problem worse (the connection cut off intermittently), and adding port 25565 to the firewall's trusted zone in an attempt to fix the problem with Minecraft. The latter caused the time before the aforementioned network connection slowdown to increase to three hours, leading me to believe that the problem is with the firewall's default settings being too Draconian for the average user.

Another possible cause I have found is the lack of support for Wireless N; I only get b/g which, to my understanding, does not have the range of n.

Thanks in advance for any help/advice,

UltrasonicMadness

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
0

answered 2013-08-12 23:57:29 -0600

meskes gravatar image

When I set up my LANs, I disable all of the internal client's firewalls, as they tend to cause issues with my LAN firewall... Of course, my LAN firewall is set up with egress filtering, meaning that I don't have any open ports that I don't need... everything is blocked by default, unless it's a port that I need to have a connection to the outside world. I also have the firewall setup to shoot me an email of any connected client's MAC that is trying to connect via any unauthorised ports, etc, that way I can contact that user and see what's up. I also filter all outgoing port 80 connections with Squid and Dansguardian, to assist with any potential phishing attempts. On my LAN, I know who, where and what all the traffic is, and if a user needs a port opened, so be it, I'll talk to them and see what it's for and then make the decision as to whether or not said port should be opened.

In short, what I recommend is that you disable all client firewalls on your desktops and set up two profiles for your portable systems; one that disables your laptop's firewall whenever you're connected to the LAN and one for when you're not.

edit flag offensive delete link more
0

answered 2013-08-12 17:08:37 -0600

ultrasonicmadness gravatar image

My Internet connection is fine now. What I did was change the firewall zone of my network connection to "trusted" in the KDE Control Module.

If this is a terrible idea, let me know (keep in mind it's my home wifi with a strong WPA key).

edit flag offensive delete link more
-1

answered 2013-08-09 22:00:19 -0600

josh3366 gravatar image

i don't know what your knowledge of what a firewall is or how it works but basically it blocks connection ports and slows or prevents unwanted programs from connecting or getting into your computer's system ... in order to host and or play games using any machine be it windows or linux or even mac you will need to forward the corresponding ports needed for the game on your router and also allow an exception for the program in the firewall itself to establish a good connection .... however as one who simply cannot be bothered i tend to disable the firewall and forward the ports on the router ... not exactly a technical answer but it's how to fix that issue

edit flag offensive delete link more

Comments

1

Disabling the firewall is not good advice. The firewall does not slow down connections. It either permits the use of a port or forbids it. It does not eat bandwidth in any way.

FranciscoD_ gravatar imageFranciscoD_ ( 2013-08-11 09:56:49 -0600 )edit

Question Tools

Stats

Asked: 2013-08-09 17:04:50 -0600

Seen: 456 times

Last updated: Aug 12 '13