Ask Your Question
0

vncserver setup in fedora 19

asked 2013-07-31 23:28:56 -0600

dksamuel gravatar image

updated 2013-08-01 05:45:27 -0600

FranciscoD_ gravatar image

please help me in the topic vncserver setup in fedora 19, I tried some methods after searching with google but thedidn'tnt work, I want to connect from windows 8 (both win 8 and linux are 64 bits)

edit retag flag offensive close merge delete

7 Answers

Sort by ยป oldest newest most voted
1

answered 2013-08-01 01:19:36 -0600

jamielinux gravatar image

What have you tried already? What guides did you use? What is the network setup of these boxes that you are trying to connect (eg, are either of them behind NAT)? What problems or specific errors have you encountered? What program are you using on Windows?

This is a good guide if you haven't already tried it: Setting up VNC on Fedora 16.

One thing people often forget is to open the appropriate firewall ports. The guide talks about iptables, but in Fedora 19 it's actually firewalld that you need to interact with to make the changes permanent. I'm an iptables diehard, so not intimately familiar with firewalld, but I think this is what you want:

firewall-cmd --permanent --zone=public --add-service vnc-server
edit flag offensive delete link more
1

answered 2013-08-10 17:58:23 -0600

rstrode gravatar image

One easy way to setup vnc is to log into GNOME and run "vino-preferences" then enable it there.

edit flag offensive delete link more
0

answered 2014-04-16 18:07:43 -0600

I think you are running into issues caused by the move to systemd in FC18. Here's a good blog post on how to configure VNC as a systemd service: http://zeusville.wordpress.com/2012/01/27/setting-up-vncserver-on-fedora-16/

edit flag offensive delete link more
0

answered 2014-05-14 21:59:52 -0600

Mouse gravatar image

VNC or Virtual Network Computing server lets you remotely control another system with a graphical desktop, in another way VNC is a desktop sharing system. You can control the remote system with your keyboard and mouse just as you are sitting How to install VNC Server on Fedora

edit flag offensive delete link more
0

answered 2013-08-02 05:16:46 -0600

dksamuel gravatar image

updated 2013-08-13 19:18:01 -0600

FranciscoD_ gravatar image

I tried the following guides http://server-world.info/en/note?os=Fedora_19&p=x&f=5 http://zeusville.wordpress.com/2012/01/27/setting-up-vncserver-on-fedora-16/

I found the server world useful and as 2 win 8 and Fedora 19 are connected by a Netgera router I issue the command systemctl stop firewalld.service to stop the firewall as i dont think the command firewall-cmd --permanent --zone=public --add-service vnc-server is enough, Now I can connect but each reboot I have to issue the commands

su
# yum -y install tigervnc-server
su - sam 
$ vncpasswd
Password:# input
Verify:# confirm
vncserver :4 -geometry 1024x768 -depth 24
su
systemctl stop firewalld.service

working on to polish the work flow, thanks so much for helping

edit flag offensive delete link more

Comments

2

Do not disable your firewall completely. Please just open the ports you need.

FranciscoD_ gravatar imageFranciscoD_ ( 2013-08-13 19:15:56 -0600 )edit
0

answered 2014-04-16 19:19:02 -0600

q2dg gravatar image

In Fedora 20, "vino-preferences" is replaced with "gnome-control-center sharing"

edit flag offensive delete link more
0

answered 2013-08-01 22:15:20 -0600

scottro gravatar image

As was mentioned, be sure to check the firewall. I have a page that I put up around Fedora 17, when the method changed.

http://home.roadrunner.com/~computertaijutsu/rhvnc.html

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-07-31 23:28:56 -0600

Seen: 44,811 times

Last updated: May 14 '14