Ask Your Question
0

Fedora 19 TigerVNC with Cinnamon instead of Gnome?

asked 2013-07-24 21:20:41 -0600

TEKUNIX gravatar image

Since Vino is completely broken in Fedora 19...:

https://bugzilla dot redhat dot com/show_bug.cgi?id=987981

And I posted a guide on how to make TigerVNC work on Fedora 19 (With Gnome, see above link)

Does anyone know how to make TigerVNC work with Cinnamon under Fedora 19?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-01-06 16:53:11 -0600

As of Fedora 19 you do not need the portion of your guide that has you edit ~/.vnc/xstartup just leave that alone, nor do you need to change the type from fork to single or add the -fg option in the vncserver@:*.service files. Without those changes, tigervnc-server will work using the plain Gnome desktop, and without some behavioural problems that the type=single and -fg you needed in Fedora 18 gave you.

To then make it use Cinnamon, all you have to do is create an executable bash script file named ~/.Xclients that contains the two lines

#!/bin/sh
exec /usr/bin/cinnamon-session

The program cinnamon-session is new in Fedora 19. The standard ~/.vnc/xstartup script uses the ~/.Xclients script if it exists instead of the default call to gnome-session.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-07-24 21:20:41 -0600

Seen: 3,432 times

Last updated: Jan 06 '14