Ask Your Question
0

Dolphin fails to open browser

asked 2013-07-21 06:33:55 -0600

Marco_A gravatar image

updated 2013-07-21 06:40:20 -0600

If I create a link to location in Dolphin (by right-clicking, Create New > Link to Location (URL)...) and click the resulting file, Dolphin tries to launch a browser, but fails. It pops up an error message: Could not find the program 'google-chrome.desktop'

I'd like to use Chrome, but I've no idea on how to tell Dolphin how to launch it for opening webpages. I haven't found options in Dolphin that allows me to configure this, nor have I found config files that have been useful (~/.kde/share/config/dolphinrc doesn't list applications it can use.)

The 'open with' option does not make Chrome open the url, but the file itself. It shows the content of the file in plain text:

[Desktop Entry]
Icon=text-html
Type=Link
URL[$e]=<url>

(I can't post the url here, because I don't have enough karma.)

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-07-21 09:38:12 -0600

cleitonlima gravatar image

The Default Applications in KDE are configurated in System Settings > Default Aplica tions. There you can configure Chrome as the default browser.

edit flag offensive delete link more

Comments

I just checked. 'google-chrome' already was the default web browser. I changed that to '/usr/bin/google-chrome'. Now link files do open, but in Konqueror. Makes no sense to me! ><

Marco_A gravatar imageMarco_A ( 2013-07-21 10:11:07 -0600 )edit

Here's some more info:

Closing already opened Dolphin windows solved the issue. Links opened in Chrome.

However, Chrome thought it wasn't the default browser anymore. Clicking 'set as default' in Chrome messed things up again.

I guess I have to change the default browser manually and make Chrome stop checking.

Marco_A gravatar imageMarco_A ( 2013-07-21 10:21:03 -0600 )edit

Question Tools

Stats

Asked: 2013-07-21 06:33:55 -0600

Seen: 739 times

Last updated: Jul 21 '13