Ask Your Question
0

Cant play MP3 [closed]

asked 2013-07-10 23:52:48 -0600

Srik gravatar image

updated 2013-07-11 23:03:15 -0600

FranciscoD_ gravatar image

Opening a MP3 file displays this message: Parole needs MPEG1-1 layer 3 decoder to play this file. It can be installed automatically. And when I click install button nothing happens. I'm using fedora 19 XFCE. Is this a bug? Pls help.

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by FranciscoD_
close date 2013-07-11 05:18:21.225334

Comments

Please search the forum before posting new questions. There are multiple questions on the subject that have already been answered. https://ask.fedoraproject.org/question/9111/what-plugins-do-i-need-to-install-to-watch-movies-and-listen-to-music/ https://ask.fedoraproject.org/question/10983/how-to-play-proprietary-audio-and-video-file-formats/ Closing as duplicate.

FranciscoD_ gravatar imageFranciscoD_ ( 2013-07-11 05:17:56 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-07-11 02:06:45 -0600

tempus gravatar image

updated 2013-07-11 02:07:30 -0600

Mp3 is a patent-encumbered format and you won't find it in the fedora repo. You need to install add the rpmfusion repositories. To cover a wide range of players (xmms, rhytmbox, audacious, amarok...):

$ su -c "yum install xmms-mp3 gstreamer-plugins-ugly audacious-plugins-freeworld-mp3 xine-lib-extras-freeworld"

Please make sure that you have installed and enabled the rpmfusion-free repo at least. For your player, gstreamer-plugins-ugly should be enough.

edit flag offensive delete link more

Comments

@tempus: That worked. I noticed few players are using gstreamer1 version while others are still using the previous version of it. Thank you.

Srik gravatar imageSrik ( 2013-07-14 20:11:58 -0600 )edit

Question Tools

Stats

Asked: 2013-07-10 23:52:48 -0600

Seen: 10,331 times

Last updated: Jul 11 '13