Ask Your Question
3

how to enable disabled repositories?

asked 2013-07-10 02:26:46 -0500

mohsen-rashidi gravatar image

updated 2016-08-15 09:12:13 -0500

florian gravatar image

Hi there. I ran yum config-manager --disable repo command for disabling one of my repositories.But it seems i disabled all of them! Now i can't install or update anything. i ran yum config-manager --enable but didn`t work. How can i fix such a mess? Thanks alot

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
3

answered 2013-07-10 06:31:57 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

The simple way is to just grab the fedora-release package and re-install it. yum config-manager should work as well. You don't seem to be using it correctly.

try: yum config-manager --enable fedora etc., i.e., provide an argument to the command.

The last option is to manually edit the repo files in /etc/yum.repos.d/ and change enabled=0 to enabled=1. Read man yum.conf for more information.

Fedora 23, 24, 25 and future

Enable repositories

dnf -y config-manager --set-enabled foo_repository

Disable repositories

dnf -y config-manager --set-disabled foo_repository
edit flag offensive delete link more
0

answered 2013-07-10 22:18:17 -0500

inkitt gravatar image

The easiest way I've found so far is to enable and disable repos through fedorautils. You just check and uncheck any repos you want any time and I've never screwed up so far.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2013-07-10 02:26:46 -0500

Seen: 4,458 times

Last updated: Aug 15 '16