Ask Your Question
1

Cannot install google-earth

asked 2013-06-29 11:56:36 -0600

MR. SCM gravatar image

updated 2013-06-30 04:53:48 -0600

FranciscoD_ gravatar image

I get this message when performing yum install google-earth-stable_current_x86_64.rpm

file /usr/bin from install of google-earth-stable-7.1.1.1871-0.x86_64 conflicts with file from package filesystem-3.1-2.fc18.x86_64
edit retag flag offensive close merge delete

Comments

4 Answers

Sort by ยป oldest newest most voted
4

answered 2013-09-04 10:51:42 -0600

mz0 gravatar image

updated 2013-09-26 02:58:45 -0600

from productforums.google.com/d/msg/earth/1P2HiHXOdHM/x3e8nfVGaYkJ

"elewis" wrote:

"Fix for 64-bit version:

  • Install rpmrebuild.

  • Run rpmrebuild -ep <name of="" package=""> downloaded from Google. rpmrebuild will open in a VIM session.

  • Look for a line: %dir %attr(0755, root, root) "/usr/bin". Delete the line. VIM command: :d or dd Use the VIM command: :wq to write changes and exit. Elect 'Y' to 'do you want to continue'.

  • Following exit, rpmrebuild will cite the location of the corrected rpm package.

Google Earth should install using yum.

Version 7.1.1 runs well on my 64-bit machine.

...."

worked for me in Fedora 19 exactly as described

edit flag offensive delete link more
0

answered 2013-09-26 03:38:11 -0600

Amit Caleechurn gravatar image

If you can't rebuild the RPM from the instructions supplied by Mz0, you can pick up the rebuilt package (x64 only) from http://sourceforge.net/projects/snowbird/files/new_dawn/RPM/

edit flag offensive delete link more
0

answered 2013-06-30 04:56:48 -0600

FranciscoD_ gravatar image

From your error description, this sounds like a packaging error. Please contact Google and let them know. There isn't anything we can do about the RPM they provide.

The rpm should not own /usr/bin. It should only own the binary it puts in /usr/bin, i.e. /usr/bin/google-earth or whatever.

Relevant Fedora packaging guideline: wiki:Packaging:Guidelines

edit flag offensive delete link more
0

answered 2014-01-08 14:03:03 -0600

elemer82 gravatar image

from https://productforums.google.com/forum/#!topic/earth/u478GSAN9no by Nils Smeds:

sudo rpm -i --force ../google-earth-stable_current_x86_64.rpm

[sudo] password for nsmeds:
Redirecting to /bin/systemctl start  atd.service

sudo rpm -q --whatprovides /usr/bin
google-earth-stable-7.1.1.1888-0.x86_64

sudo yum reinstall filesystem
sudo rpm -q --whatprovides /usr/bin

filesystem-3.2-13.fc19.x86_64

I have done this way. After 30 minutes still works. If stops I let you know.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2013-06-29 11:56:36 -0600

Seen: 2,424 times

Last updated: Jan 08 '14