Ask Your Question
0

Fedora 19 yum proxy setting [closed]

asked 2013-05-29 03:54:45 -0600

japo gravatar image

updated 2013-06-03 06:51:40 -0600

Does anybody know how to go behind the proxy with fedora 19? If I add the proxy= … Proxy_username=… ,proxy_password=… lines in my yum.conf file it still won’t work thanks

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Akshay
close date 2013-08-11 15:17:58.088661

Comments

It should work. Could you please add a sample configuration you use (certainly without actual username/password/proxy URL)? What kind of output do you get? You can also put your proxy info into http_proxy AND https_proxy environment variables: export http_proxy=http://username@password:proxy.domain.com:port and export https_proxy=$http_proxy

hedayat gravatar imagehedayat ( 2013-06-13 02:09:07 -0600 )edit

yum doesn't pick proxy information from the environment variables as far as I know. The only place it takes this info is from the yum.conf file.

FranciscoD_ gravatar imageFranciscoD_ ( 2013-06-13 07:06:56 -0600 )edit

I have used environment variables with yum in the past. And I tested Yum right now with a fake proxy (e.g. 127.0.0.1:9000 which doesn't exist) and put it into http_proxy AND https_proxy variables. Now, yum is unable to connect to anywhere. So, it seems that it works. :)

hedayat gravatar imagehedayat ( 2013-06-13 15:00:41 -0600 )edit

i had added the following lines in the yum.conf [without quotes] "proxy=http://myproxyaddress:8080" proxy_username=user proxy_password=passwd

and export the environment variables for http_proxy and https_proxy but i yum is unable to connect and give following error..

[root@fedora19 ~]# yum update Loaded plugins: langpacks, refresh-packagekit Error: Cannot retrieve metalink for repository: fedora/19/x86_64. Please verify its path and try again [root@fedora19 ~]#

ashishsinghdev gravatar imageashishsinghdev ( 2013-08-11 09:56:18 -0600 )edit

5 Answers

Sort by » oldest newest most voted
0

answered 2013-06-11 06:10:35 -0600

hi download python-urlgrabber-3.9.1-27.fc19.noarch.rpm (last package form update-testing) and optionally last yum package, this work for me. regard Roberto Freguia

edit flag offensive delete link more
1

answered 2013-06-12 21:36:01 -0600

mhjacks gravatar image

I think you need the following settings if you have a proxy that requires authentication:

proxy=http://yourproxy.yourdomain.com:3128 (or differ
proxyusername=you
proxy
password=yourpasswd

The keys are probably case sensitive. I have used Fedora 19 with an authetnicating proxy successfully with these settings.

edit flag offensive delete link more
0

answered 2013-05-30 05:29:37 -0600

FranciscoD_ gravatar image

As far as I know, the only way of providing proxy information to yum is via yum.conf. Please double check if you've used the correct information. I've used it and it works.

man yum.conf #for details.

Please note that this is only for yum. For the rest, you can use your desktop environment's settings.

edit flag offensive delete link more
0

answered 2013-06-14 04:09:16 -0600

japo gravatar image

Thank for the reply, I find out that if I connect my device immediately to the network and then do the first “yum update “ it works after that. So I didn’t try the python-urlgrabber-3.9.1-27.fc19 solution as mentioned before but it probably can work also. Thanks

edit flag offensive delete link more
-1

answered 2013-06-13 06:36:14 -0600

q2dg gravatar image

What about dnf?

edit flag offensive delete link more

Comments

dnf will follow the same configuration options as yum.

FranciscoD_ gravatar imageFranciscoD_ ( 2013-06-13 07:06:02 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2013-05-29 03:54:45 -0600

Seen: 10,524 times

Last updated: Aug 11 '13