Ask Your Question
1

Graphical tool to change CPU frequency on Fedora 19 with GNOME Shell?

asked 2013-05-21 09:40:00 -0500

remjg gravatar image

updated 2014-09-29 04:46:21 -0500

mether gravatar image

In order to avoid unexpected shutdowns of my laptop, I need sometimes to manually lower the CPU frequency. Under GNOME Shell 3.6 (on Ubuntu 12.10 GNOME), I've been using the CPU Freq extension that worked pretty well.

In the meantime, I've switched to GNOME Shell 3.8 (on Fedora 19) and I can't activate this extension anymore from the website. I know this is still a development version but I had a disastrous experience with Ubuntu GNOME 13.04 which made me switch a bit earlier.

How can I change graphically the CPU frequency on Fedora 19 under GNOME Shell 3.8?

edit retag flag offensive close merge delete

Comments

I've been able to download the extension from github and to install it with GNOME Tweak Tool. Unfortunately, I need to install cpufreq-selector which I can't find it in the repositories...

remjg gravatar imageremjg ( 2013-05-21 09:55:30 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2013-05-21 12:41:40 -0500

mether gravatar image

cpufreq-selector is part of gnome-applets package. Tip: If you know the filename but not the package name, you can let yum figure it out, using yum install /*cpufreq-selector

edit flag offensive delete link more

Comments

Thank you for the tip, it's quite convenient! Unfortunately, in Fedora 19 there is no such package (and gnome-applets is not in the repository I have). I tried to install mate-applets before, but it didn't help.

remjg gravatar imageremjg ( 2013-05-21 13:59:43 -0500 )edit

You can try yum --releasever=18 install gnome-applets. The extension should ideally be modified to use a more modern alternative.

mether gravatar imagemether ( 2013-05-21 14:23:24 -0500 )edit

I tried the command you wrote with the --skip-broken option, but it failed to install because of dependency problems... Maybe I'll have to wait for a new extension! Thank you very much for you answers.

remjg gravatar imageremjg ( 2013-05-21 16:10:51 -0500 )edit

In the meantime, I found this command to reduce the CPU frequency: sudo cpupower frequency-set -g powersave.

remjg gravatar imageremjg ( 2013-05-21 16:41:12 -0500 )edit

yeah. perhaps you can file a feature request with the extension developer to support this

mether gravatar imagemether ( 2013-05-21 17:32:44 -0500 )edit

Question Tools

Stats

Asked: 2013-05-21 09:40:00 -0500

Seen: 6,024 times

Last updated: Oct 02 '13