Ask Your Question
1

yum update error: conflict between libselinux-utils-2.1.6-6.fc16.x86_64 and libselinux-2.1.6-6.fc16.x86_64 [closed]

asked 2013-04-20 01:38:56 -0600

bambu gravatar image

updated 2014-09-28 12:10:07 -0600

mether gravatar image

Hi ,

I am a new user of fedora. I aM USING fedora-16

while I am updating my fedora using

yum update --skip-broken

I find the following errors:

Transaction Check Error:
  file /usr/sbin/matchpathcon conflicts between attempted installs of libselinux-utils-2.1.6-6.fc16.x86_64 and libselinux-2.1.6-6.fc16.x86_64

How can I solve this problem !!! I am wondering

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by davidva
close date 2017-08-07 23:16:54.016461

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-08-07 15:09:38 -0600

dehvokahn gravatar image

This is an old question (4 years old!), however I have experience with this that I wanted to share, in case anyone else arrives to this question with a similar problem.

So, you are trying to install some software or update fefdora and when using yum update --skip-broken you get an error message similar to Transaction Check Error: file /path/to/file conflicts betwen attempted installs of some-package-#.#.#-#.fc##.<arch> and other-package-#.#.#-#.fc##.<arch>

The following should solve this problem (borrowed from https://access.redhat.com/solutions/1... and my own work experience):


Option 1:

  • First, install yum-utils:

    sudo yum install yum-utils`
    
  • Now, list any duplicate packages:

    package-cleanup --dupes`
    
  • Now, we want to clean up any package dupes [WARN: this only cleans up the yum/rpm databases, depeneding on your version of yum/rpm/berkleydb]

    package-cleanup --cleandupes`
    
  • OPTIONAL: If you have issues with conflicts between packages of different architectures, then you want to force yum update to only install packages of the same architecture when updates are available, so i686 will not overwrite x86_64, etc ... to do this, configure yum.conf with the following line:

    sudo vim /etc/yum.conf

    Then adjust the line with exactarch to equal 1 (or append this line to the file if exactarch is not there):

    exactarch=1

    From the yum.conf manpage ( https://linux.die.net/man/5/yum.conf ):


    exactarch

    Either '1' or '0'. Set to '1' to make yum update only update the architectures of packages that you have installed. ie: with this enabled yum will not install an i686 package to update an i386 package. Default is '1'.

  • clean yum, then try the update again:

    sudo yum clean all
    sudo yum update
    

Option 2:

If you are not online, or there is some special circumstance that is preventing the above from working, you might be able to forcefully replace the problem files with the rpm command, given you have the rpm file available:

rpm -Uvh --replacefiles some-package-*.rpm

NOTE: The yum system is quite complex. This issue should only happen when the yum database or rpm database (rpmdb) thinks there is a package installed that requires a file that a package to be updated needs to replace, or when two packages are installed that use different versions of the same package, or any number of other related special cases. These issues can be caused when a yum or rpm database become corrupted, packages are installed manually and then the metadata only added to the yum or rpm database, or by other many other special edge cases. It should be known that messing with the yum or rpm databases could cause irreparable damage to your system. Be ready with a full system backup, or know that you may need to re-install your OS if you run into problems. If you have further questions about a yum issue, or a packaging issue on a RedHat or Fedora system, please post a question here on ask.fedoraproject.org and then send me a private ...

(more)
edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-04-20 01:38:56 -0600

Seen: 938 times

Last updated: Aug 07 '17