Ask Your Question
0

httpd service failed to start

asked 2013-04-03 06:55:36 -0600

suthar gravatar image

updated 2013-04-11 00:04:01 -0600

i am using fedora 18 with required packages to start httpd service but it is failed to start. I am getting following errors-

-------------------------------------------------------------
[root@air-book suthar]# systemctl start httpd
Job for httpd.service failed. See 'systemctl status httpd.service' and 'journalctl -xn' for details.
[root@air-book suthar]# systemctl status httpd.service
httpd.service - The Apache HTTP Server
      Loaded: loaded (/usr/lib/systemd/system/httpd.service; disabled)
      Active: failed (Result: exit-code) since Wed 2013-04-03 17:06:41 IST; 14s ago
     Process: 21718 ExecStop=/usr/sbin/httpd $OPTIONS -k graceful-stop (code=exited, status=0/SUCCESS)
     Process: 21713 ExecStart=/usr/sbin/httpd $OPTIONS -DFOREGROUND (code=exited, status=1/FAILURE)

Apr 03 17:05:52 air-book httpd[21713]: AH00557: httpd: apr_sockaddr_info_get() failed for air-book
Apr 03 17:05:52 air-book httpd[21713]: AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using 127.0....s message
Apr 03 17:06:23 air-book systemd[1]: httpd.service: main process exited, code=exited, status=1/FAILURE
Apr 03 17:06:41 air-book httpd[21718]: AH00557: httpd: apr_sockaddr_info_get() failed for air-book
Apr 03 17:06:41 air-book httpd[21718]: AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using 127.0....s message
Apr 03 17:06:41 air-book httpd[21718]: httpd (no pid file) not running
Apr 03 17:06:41 air-book systemd[1]: Failed to start The Apache HTTP Server.
Apr 03 17:06:41 air-book systemd[1]: Unit httpd.service entered failed state
---------------------------------------------------------------------------------

link to download my /etc/hosts and /etc/httpd/conf/httpd.conf files... /etc/hosts /etc/httpd/conf/httpd.conf

please help me.

edit retag flag offensive close merge delete

Comments

wow, I corrected it !!! thanx to yogi.sg. really very very thanks.

http://www.yodi.sg/fix-httpd-apache-wont-start-problem-in-fedora-18/

suthar gravatar imagesuthar ( 2013-04-28 02:21:49 -0600 )edit

4 Answers

Sort by » oldest newest most voted
0

answered 2013-04-03 08:07:55 -0600

ThomasMcA gravatar image

My hunch is that your hosts file does not include a valid FQDN. An FQDN must include a hostname part, as well as a domain name part. For example, the following is a valid FQDN:

host.yourcompany.com

Choose a FQDN and include it both in your /etc/hosts file on both the IPv4 and IPv6 localhost entries, and change your ServerName in your httpd configuration to match.

edit flag offensive delete link more

Comments

Thanks Thomas, but I failed. so please tell me in detail where to edit and how with example. I will be graceful.

suthar gravatar imagesuthar ( 2013-04-05 10:17:04 -0600 )edit

Please attach your /etc/hosts and /etc/httpd/conf/httpd.conf files.

ThomasMcA gravatar imageThomasMcA ( 2013-04-05 11:04:50 -0600 )edit

i attached.

suthar gravatar imagesuthar ( 2013-04-11 00:04:20 -0600 )edit
0

answered 2013-04-11 11:31:04 -0600

nebjak gravatar image

Add

ServerName localhost

to /etc/httpd/conf/httpd.conf

edit flag offensive delete link more

Comments

it doesn't work......

suthar gravatar imagesuthar ( 2013-04-12 02:24:59 -0600 )edit
0

answered 2013-04-11 06:04:53 -0600

wholevin gravatar image
edit flag offensive delete link more
0

answered 2015-09-10 07:00:00 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

Olá pessoal, bom dia esse erro acontece porque removemos a pasta html, vá no httpd.conf e altare a linha sem o caminho da pasta html.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-04-03 06:55:36 -0600

Seen: 15,969 times

Last updated: Apr 29 '13