Ask Your Question
0

Fixing Grub2 after installing Fedora 18 on a Windows 8 Machine?

asked 2013-03-17 02:41:14 -0600

ahager gravatar image

I have been playing around with Linux for a few years now, but I've never dived in all the way. I love the ideas behind Linux, and I refuse to have a laptop without it anymore. But I have to have a dual-boot setup.

Grub2 has a known bug after installing in an EFI environment, it exists in Ubuntu 12.10 as well. I would like someone to give me a little help in fixing this so I can boot into Windows where required.

In Ubuntu, I can use boot-repair to fix it all with one click. It worked on all three spins, and you can find it on google, I tried to post the link but my karma is insufficient. :)

Is there anyway I can use tars in Fedora, and would any of you be so kind as to walk me through that or the steps I need to reconfigure grub manually? I am new to fedora and used to the Ubuntu way of doing things, so detailed help would be appreciated.

Thank you all for your time!

edit retag flag offensive close merge delete

Comments

Please note that I can boot into Windows 8 by simply typing exit into Grub, but I would like to fix the broken menu entries in there as well, so again, any help is very much appreciated!

ahager gravatar imageahager ( 2013-03-17 03:10:15 -0600 )edit

I've now edited the scripts found in /etc/grub.d but to no avail. I added in a script for Windows to execute the exit command, that would be good enough for me, but even after I update grub2 it doesn't change the menu itself. The changes are the show in the grub file, but they don't appear when booting, then I used efibootmgr.

ahager gravatar imageahager ( 2013-03-17 04:37:57 -0600 )edit

Boot0001* Fedora HD(7,34e76000,64000,2f213991-83fd-462c-abf7-01d6175863c8)File(\EFI\fedora\shim.efi) Boot0002* Windows Boot Manager HD(1,800,96000,b5117df1-3bf8-40f5-8a71-b3761ff7b29d)File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...M................

ahager gravatar imageahager ( 2013-03-17 04:39:58 -0600 )edit

Not sure if that will help, but I figured I would share it, also there are leftover bits from Ubuntu in there apparently, not that it should hurt anything, just trying to provide as much data as I can.

ahager gravatar imageahager ( 2013-03-17 04:41:17 -0600 )edit

Please can you explain which known bug are you referring to?

keramidas gravatar imagekeramidas ( 2013-03-17 05:20:32 -0600 )edit

3 Answers

Sort by ยป oldest newest most voted
0

answered 2013-03-17 06:18:47 -0600

FranciscoD_ gravatar image

This page might have some tips: http://fedoraproject.org/wiki/Grub2

edit flag offensive delete link more

Comments

I have followed the instructions on that page closely, and thank you or sharing it, but when I edit the files in /etc/grub.d and then run the grub2-mkconfig command, it never actually changes my menu in Grub.

ahager gravatar imageahager ( 2013-03-17 23:48:56 -0600 )edit
0

answered 2013-03-18 11:33:22 -0600

keramidas gravatar image

updated 2013-03-18 11:34:50 -0600

One thing you should pay attention to is that UEFI is in charge to choose your booting OS (most times by pressing F12) and not GRUB. Please check this link to find out if this helps you. http://fedoraproject.org/wiki/CommonF18bugs#Windows8installedinUEFImodearenotpresentintheFedorabootloader_menu

edit flag offensive delete link more
0

answered 2013-03-18 00:04:01 -0600

ahager gravatar image

I can tell I was tired when I was working on this yesterday, the fix for me was simple. I was editing the wrong files.

I've read a lot of material on grub2 and efi, and I don't remember seeing this anywhere so perhaps it's how Fedora's release handles it, but the files that needed changed were found in /etc/grub2-efi.cfg - Once I edited that file, and again ran the grub2-mkconfig command the menu entries that I added were finally shown. Now my Grub2 is nice and neat, and when I select Windows 8 it boots. It's not an actual boot script, however, just a simple menuentry 'Windows 8' {exit}

Again, not the perfect fix but it worked for me.

edit flag offensive delete link more

Comments

I just wanted to reiterate this point as I'm seeing a lot of users still having the same troubles I did.

ahager gravatar imageahager ( 2013-04-23 00:23:21 -0600 )edit

Anytime you want to edit Grub in an EFI setup, under Fedora 18, make sure the files you edit are located in /etc/grub2-efi.cfg - The normal grub2.cfg will not update in this scenario. I hope this helps all others that are in the same shoes I was in.

ahager gravatar imageahager ( 2013-04-23 00:24:37 -0600 )edit

Question Tools

Stats

Asked: 2013-03-17 02:41:14 -0600

Seen: 9,032 times

Last updated: Mar 18 '13