Ask Your Question
0

Mouse and keyboard not working after upgrade to F18 from F17

asked 2013-03-05 01:30:19 -0600

srinath gravatar image

Recently, I upgraded my laptop from Fedora 17 to Fedora 18 using the FedUp tool.

After the upgrade, the machine booted up and shows the login screen. On the screen, I'm unable to use the keyboard or the mouse pointing device. They don't work. Tried connecting another (external) keyboard and mouse pointing device via USB port. They don't work as well. I booted the machine into Windows - mouse and keyboard work fine there. Also booted the machine using the Live Fedora media - the mouse and keyboard work fine there too.

Can you help me resolve this issue?

The laptop is a dual boot machine (Windows + Fedora Linux)

edit retag flag offensive close merge delete

Comments

Can you access a virtual terminal, ie, does pressing "ctrl alt f2" work? If not, we'll try booting into console mode and collecting some logs.

FranciscoD_ gravatar imageFranciscoD_ ( 2013-03-05 02:42:39 -0600 )edit

Hi FranciscoD_, Thanks for the reply. You mean Ctrl+Alt+F2 on the login screen. If so, that did not work.

srinath gravatar imagesrinath ( 2013-03-05 03:09:53 -0600 )edit

Hi @srinath: Please try booting in run level 3 as instructed here and see if your mouse/keyboard works? If it does, please try running the steps given here to clean up your system after the upgrade and see if that helps. If you do manage to login, also look at the logs: dmesg, /var/log/messages, /var/log/Xorg.0.log for anything suspicious.

FranciscoD_ gravatar imageFranciscoD_ ( 2013-03-05 17:17:42 -0600 )edit

Hi @FranciscoD_, I was performing the upgrade cleanup tasks. After relabelling (step 4), the machine rebooted and booted into normal mode (level 5) and the mouse and keyboard worked well. Should I continue with the rest of the steps?

srinath gravatar imagesrinath ( 2013-03-06 04:40:31 -0600 )edit

I suggest you complete all the steps. There may be other issues that crop up later :)

If relabelling fixed it, it was probably an selinux issue.

Please mark the answer I've given below as correct @srinath. It will help others. Thanks :)

FranciscoD_ gravatar imageFranciscoD_ ( 2013-03-18 21:51:55 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-03-18 21:53:32 -0600

FranciscoD_ gravatar image

Booting into runlevel 3 and cleaning up the system after the upgrade seems to have fixed the issue for the reporter.

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2013-03-05 01:30:19 -0600

Seen: 3,794 times

Last updated: Mar 18 '13