Fedora 17/18: X crashes on first login

asked 2013-03-03 20:29:06 -0500

telotortium gravatar image

updated 2014-09-29 00:33:00 -0500

mether gravatar image

Whenever my Fedora 17 (recently upgraded to 18 with fedup) first boots to the display manager (it's gdm right now, but I remember it happening with kdm as well), invariably after I log in for the first time, X seems to crash after about 3 to 5 seconds, dumping me back to the login screen. After entering my credentials again, I stay logged in - X doesn't crash again. I normally run xmonad as my window manager, but this happens with any window manager (KDE and Gnome). ~/xsession-errors.old (after I log in successfully) contains errors concerning programs losing their connection to the X server, but nothing that I can use to diagnose the cause, and the files in /var/log/gdm are not exactly obvious to me, although here is the contents of /var/log/gdm/:0-greeter.log.1:

      JS LOG: GNOME Shell started at Sun Mar 03 2013 18:46:55 GMT-0600 (CST)
Window manager warning: CurrentTime used to choose focus window; focus window may not be correct.
Window manager warning: Got a request to focus the no_focus_window with a timestamp of 0.  This shouldn't happen!
gnome-session[2514]: WARNING: Detected that screensaver has left the bus
gnome-session[2514]: CRITICAL: gsm_manager_set_phase: assertion `GSM_IS_MANAGER (manager)' failed

(gnome-settings-daemon:2538): GLib-GIO-WARNING **: Error releasing name org.gnome.SettingsDaemon: The connection is closed
g_dbus_connection_real_closed: Remote peer vanished with error: Error receiving message: Connection reset by peer (g-io-error-quark, 0). Exiting.
Window manager warning: Log level 8: g_source_remove: assertion `tag > 0' failed

(gnome-settings-daemon:2538): wacom-plugin-CRITICAL **: gsd_wacom_device_get_device_type: assertion `GSD_IS_WACOM_DEVICE (device)' failed

(gnome-settings-daemon:2538): wacom-plugin-CRITICAL **: gsd_wacom_device_get_device_type: assertion `GSD_IS_WACOM_DEVICE (device)' failed

(gnome-settings-daemon:2538): wacom-plugin-CRITICAL **: gsd_wacom_device_get_device_type: assertion `GSD_IS_WACOM_DEVICE (device)' failed

(gnome-settings-daemon:2538): wacom-plugin-CRITICAL **: gsd_wacom_device_get_device_type: assertion `GSD_IS_WACOM_DEVICE (device)' failed

(gnome-settings-daemon:2538): wacom-plugin-CRITICAL **: gsd_wacom_device_get_device_type: assertion `GSD_IS_WACOM_DEVICE (device)' failed

(gnome-settings-daemon:2538): wacom-plugin-CRITICAL **: gsd_wacom_device_get_device_type: assertion `GSD_IS_WACOM_DEVICE (device)' failed

(gnome-settings-daemon:2538): wacom-plugin-CRITICAL **: gsd_wacom_device_get_device_type: assertion `GSD_IS_WACOM_DEVICE (device)' failed

(gnome-settings-daemon:2538): GLib-GIO-WARNING **: Error releasing name org.freedesktop.ScreenSaver: The connection is closed

In case this might be helpful, here are a couple of relevant package versions:

  • xorg-x11-drv-nvidia: 304.64
  • gdm: 3.6.2-5
  • xmonad: 0.11
  • xorg-x11-server-Xorg: 1.13.2-4
edit retag flag offensive close merge delete

Comments

If X is crashing, the related errors will be in /var/log/Xorg.0.log. Could you grep the file for "EE" and see if you find anything?

FranciscoD_ gravatar imageFranciscoD_ ( 2013-03-04 04:54:43 -0500 )edit