Ask Your Question
0

Dependency Resolution Errors

asked 2013-03-02 15:22:13 -0600

elenucanuca gravatar image

updated 2013-03-03 19:06:11 -0600

FranciscoD_ gravatar image

Hello, I have problems with dependences, i'm a noob so I will paste below the error message from Yum Extender. I also have problems with Arista Transcoder that isn't starting, maybe because of these errors... Please help me!

Dependency Resolution Errors:
Package: rpmfusion-nonfree-release-19-0.2.noarch (rpmfusion-nonfree-rawhide)
    Requires: system-release >= 19
    Installed: fedora-release-18-1.noarch (@koji-override-0/$releasever)
        system-release = 18-1
    Available: generic-release-18-1.noarch (fedora)
        system-release = 18-1Package: gstreamer-plugins-ugly-0.10.19-10.fc19.i686 (rpmfusion-free-rawhide)
    Requires: libcdio.so.14(CDIO_14)Package: rpmfusion-free-release-19-0.2.noarch (rpmfusion-free-rawhide)
    Requires: system-release >= 19
    Installed: fedora-release-18-1.noarch (@koji-override-0/$releasever)
        system-release = 18-1
    Available: generic-release-18-1.noarch (fedora)
        system-release = 18-1Package: gstreamer-plugins-ugly-0.10.19-10.fc19.i686 (rpmfusion-free-rawhide)
    Requires: libcdio.so.14Package: gstreamer-plugins-bad-0.10.23-3.fc19.i686 (rpmfusion-free-rawhide)
    Requires: libgnutls.so.28
edit retag flag offensive close merge delete

Comments

Thank you so much for your fast answer! I'll do everything you told me and if I have problems I will return.

I tried "yum build-dep gstreamer-plugins-ugly-0.10.19-10.fc19.i686" but this is what the terminal shows: "No such command: build-dep. Please use /usr/bin/yum --help" I don't know what this means...

elenucanuca gravatar imageelenucanuca ( 2013-03-02 15:54:21 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-03-03 19:12:35 -0600

FranciscoD_ gravatar image

Why are you running rpmfusion rawhide? Is this intentional, or are you installing the wrong rpm? If you want to run rawhide, you first need to update Fedora to rawhide and then install rpmfusion for rawhide.

As the wiki page would've clearly mentioned, rawhide is for testing purposes. It is not advised for day to day use. It's the development release, not the stable release.

If you've gotten the wrong rpm, just get the correct rpm and there won't be any other dependency issues.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-03-02 15:22:13 -0600

Seen: 961 times

Last updated: Mar 03 '13