Ask Your Question
0

Fedora 17 x86_64 problems with wifi on Lenovo T520

asked 2013-02-21 23:58:00 -0500

key_mkm gravatar image

Hi,

First of all Sorry for my terrible English.

I have problem with WiFi on my laptop Lenovo T520 with Fedora 17 x86_64. When WiFi signal is strong enough (when I close to WiFi point) everything is perfect, But when signal is weak troubles beginning. I couldn't connect or connection periodically close. I have two systems on my laptop Fedora and Windows 7. When I boot Win7 in the same conditions everything work perfect. O, almost forgot. I detect one strange thing. Even if WiFi signal already lost indicator in tray shows that everything fine (about 3 points).

Information about WiFi adapter in Hardware manager: RTL8188CE 802.11b/g/n WiFi Adapter;

Thanks in advance for the help

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-02-22 08:26:30 -0500

You may be able to boost the adapter's transmit power. Get the interface name of your WiFi card from the output of "iwconfig" and try this (replace "eth0" with your interface name):

iwconfig eth0 txpower 20

Most adapters max out around 20, but you could try higher numbers too.

edit flag offensive delete link more

Comments

Thanks a lot for the answer. I try this command but situation is the same.

key_mkm gravatar imagekey_mkm ( 2013-02-27 01:38:18 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2013-02-21 23:58:00 -0500

Seen: 593 times

Last updated: Feb 22 '13