Ask Your Question
2

Fedora 18: 50-60% CPU Load streaming video

asked 2013-02-21 16:12:27 -0600

freax gravatar image

Hi,

if I´m watching a video (Firefox or Chromium) my CPU Load goes up to 50-60% even if I don´t use FlashPlayer and watch Videos on YouTube with HTML5...

I have an HP Probook 4720s with an Intel I3-350M (2,27Ghz) and an ATI Mobility Radeon HD4500 Graphic card.

Has anybody an idea how to fix this? Should I use the ATI-Catalyst Driver?

But as fare as I know they don´t support the new X-Server Version anymore, or am I wrong?!?

edit retag flag offensive close merge delete

Comments

I'm not sure if it's supported or not, but my advise is to try another grpahic card driver to see, if the cpu load is smaller. Also, what graphic card driver are you using now? Can you do a top, when seeing a movie so we can see what process is taking up your cpu?

lnxslck gravatar imagelnxslck ( 2013-02-21 19:16:34 -0600 )edit

Currently I´m using the Driver that comes with Fedora, I´m not sure which exactly this is and which alternative driver do you suggest? To the second Question, when I´m watching a movie with Firefox the Process List ordered by CPU shows Firefox on the Top with 50-60%...

freax gravatar imagefreax ( 2013-02-22 01:35:08 -0600 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2013-02-22 09:44:11 -0600

updated 2013-02-22 09:48:26 -0600

You may have a better performance installing catalyst legacy drivers, avaiable from rpmfusion repository.

Then install the following packages

  1. akmod-catalyst-legacy
  2. xorg-x11-drv-catalyst-legacy-libs
  3. xorg-x11-drv-catalyst-legacy

Open a console and type:

sudo yum install akmod-catalyst-legacy  xorg-x11-drv-catalyst-legacy-libs  xorg-x11-drv-catalyst-legacy

You can also install the proprietary driver from AMD.

Go to this page

edit flag offensive delete link more

Comments

i will give it a try, thanks for the good answer!

freax gravatar imagefreax ( 2013-02-22 12:11:10 -0600 )edit

looks like currently amd´s catalyst-legacy driver doesn´t support xorg 1.13, do you know how to downgrade to xorg 1.12?

freax gravatar imagefreax ( 2013-02-24 16:26:27 -0600 )edit

I do not advise you to do that, it most certain will break your Xorg and you won't be able to have a graphical environment again. Even if it says that doesn't support it, did you tried to install it?

lnxslck gravatar imagelnxslck ( 2013-02-24 17:31:58 -0600 )edit

If you really want to try and downgrade xorg, you can remove it, and then install it by specifying the exat version of the xorg packages you want, for example sudo yum install xorg-server-1.12

lnxslck gravatar imagelnxslck ( 2013-02-24 17:33:43 -0600 )edit

according to this post https://ask.fedoraproject.org/question/10924/how-to-install-updated-amd-catalyst-legacy-131/ it is not possible to use the catalyst-legacy driver with xorg 1.13, I will try downgrading to xorg 1.12 like it´s described in this post, hopefully i don´t break it ^^

freax gravatar imagefreax ( 2013-02-25 15:03:38 -0600 )edit

Question Tools

Stats

Asked: 2013-02-21 16:12:27 -0600

Seen: 555 times

Last updated: Feb 22 '13