F29: Sound turning on "magically"

asked 2019-04-25 12:43:33 -0600

langdon gravatar image

One of my favorite things about Fedora? Gnome? is that it remembers the status of the sound across reboots and devices. I normally keep sound muted without headphones except once in a while. Up until a week or two ago, my sound status would be remembered between headphones connected and not and between being put to sleep and waking up. Now, the sound turns back on semi-randomly. I think it may be from disconnecting headphones or waking from sleep but it also seems to happen some other times as well.

Is this a bug that should be reported? Did some config change that changed this behavior? Something else? I have no idea how to begin to troubleshoot it and would love any help with that.

edit retag flag offensive close merge delete

Comments

sounds like it.

rdtcustomercare gravatar imagerdtcustomercare ( 2019-04-26 02:56:32 -0600 )edit

@langdon, just an observation/question to you. I rarely unplug headphones at home, and, in reverse, rarely plug them in at work. From my experience, system actually remembers sound levels for various outputs independently -- i.e. one level for headphones, another for speakers (i.e. headphones unplugged).

Did a quick test just now, it behaves as I say, it remembers two different levels for me.

Isn't that what gets you confused? If I understand your post correctly, you expect for level not to change when you unplug/plug in you headphones, and that's not how it works for me.

Night Romantic gravatar imageNight Romantic ( 2019-04-26 05:03:35 -0600 )edit

No, the problem is that it is not behaving the way you just described (remembering independent volumes for w/ & w/o headphones) anymore. And, it also seems to (sometimes) not remember the sound setting when waking from sleep.

I suspect this feature may be configurable somewhere and I got some update or did something that turned it off without knowing it.

langdon gravatar imagelangdon ( 2019-04-26 20:22:21 -0600 )edit