Ask Your Question
0

Reboot time takes about 5 minutes

asked 2019-04-24 11:17:03 -0600

bojohnson02 gravatar image

I'm running Fedora 29 and every time I reboot my laptop, it takes several minutes. I've read that I might need to push a bunch of keys to increase the entropy, something to do with the random number generator in the kernel, but I think this was a problem with an older version. The only thing that worked as putting SELinux in permissive mode, where it booted right up super fast. So it seems like something is up with the SELinux thing. Any ideas on how to fix this issue without changing the mode in SELinux?

edit retag flag offensive close merge delete

Comments

See what's in the logs with journalctl -b. You can press ESC at boot time to see where the boot process is getting stuck.

fcomida gravatar imagefcomida ( 2019-04-24 11:38:48 -0600 )edit

systemd-analyze blame and systemd-analyze critical-chain can help you identify the delaying processes.

florian gravatar imageflorian ( 2019-04-24 23:40:09 -0600 )edit

I tried both journalctl -b, systemd-analyze blame, and system-analyze critical-chain, but there were only items that took maybe a max of 7 seconds, not what I thought would be keeping the reboot process going for 5 minutes.

So some more information probably might help. The reboot process gets stuck when the first Fedora logo appears on reboot, not on the second time it shows up. Could that be making any difference?

bojohnson02 gravatar imagebojohnson02 ( 2019-04-25 23:00:57 -0600 )edit

if you can see where it "stops", can you name the service ?

rdtcustomercare gravatar imagerdtcustomercare ( 2019-04-26 03:01:01 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2019-04-27 08:54:00 -0600

jmt gravatar image

You could boot your system without the the "rhgb" and "quiet" flags on the kernel parameters. The graphical boot is pretty but it hides vital information on the boot process.

edit flag offensive delete link more
0

answered 2019-04-24 13:31:35 -0600

sixpack13 gravatar image

maybe

sudo touch /.autorelabel

and a reboot might help.

- currently don't know if it helps for "selinux in permissive mode" -

and/or installation of "setroubleshoot" and further investigation

what systemd services causes long boot time:

systemd-analyze plot > /tmp/boot-graph.svg && firefox /tmp/boot-graph.svg
edit flag offensive delete link more

Comments

I tried the sudo touch /.autorelabel and rebooted, a couple of times actually, and I'm still getting stuck for a while. The boot process is getting stuck on the first Fedora logo on shutting down, not on the second Fedora logo upon restarting. Could that make any difference?

bojohnson02 gravatar imagebojohnson02 ( 2019-04-25 23:02:22 -0600 )edit

something tries to build i.e. a kernel mod, the man page database, packagekit etc. etc. PRESS ESC and see for yourself.

rdtcustomercare gravatar imagerdtcustomercare ( 2019-04-26 03:02:34 -0600 )edit

The boot process is getting stuck on the first Fedora logo on shutting down, not on the second Fedora logo upon restarting.

Yes means something (service, program, disk mount) is having trouble gracefully shutting down - and the system is waiting for that to time out before proceeding anyway.

You can do:

journalctl -b -1 --no-pager

to access system logs from previous boot ("-b -1") and see what it was, just scroll up until you see a "gap" in timestamps on the left and some message about "waiting" for something nearby. Eventually you'll see a line saying "System is rebooting".

Kostya Vasilyev gravatar imageKostya Vasilyev ( 2019-04-27 09:39:42 -0600 )edit

Question Tools

2 followers

Stats

Asked: 2019-04-24 11:17:03 -0600

Seen: 147 times

Last updated: Apr 27 '19