Ask Your Question
0

Upgrade Collision form Fedora 28 --> 29

asked 2019-04-21 16:57:23 -0600

TalGloz gravatar image

updated 2019-04-22 01:10:08 -0600

When I upgrade my Fedora workstation from 28 to 29 I get this output:

Error: Transaction verification error: File /usr/lib64/libicudata.so.62.1 from the installation of libicu-62.1-3.fc29.x86_64 conflicts with the file from package libicu62-62.1-3.fc28.remi.x86_64
File /usr/lib64/libicui18n.so.62.1 from the installation of libicu-62.1-3.fc29.x86_64 conflicts with the file from package libicu62-62.1-3.fc28.remi.x86_64
File /usr/lib64/libicuio.so.62.1 from the installation of libicu-62.1-3.fc29.x86_64 conflicts with the file from package libicu62-62.1-3.fc28.remi.x86_64
File /usr/lib64/libicutest.so.62.1 from the installation of libicu-62.1-3.fc29.x86_64 collides with the file from package libicu62-62.1-3.fc28.remi.x86_64
File /usr/lib64/libicutu.so.62.1 from the installation of libicu-62.1-3.fc29.x86_64 conflicts with the file from package libicu62-62.1-3.fc28.remi.x86_64
File /usr/lib64/libicuuc.so.62.1 from the installation of libicu-62.1-3.fc29.x86_64 conflicts with the file from package libicu62-62.1-3.fc28.remi.x86_64

I have those collisions and I can’t go further with my upgrade, is there a way to go around it or remove the colliding files?

edit retag flag offensive close merge delete

Comments

You can try the upgrade command with

--allowerasing
stonedrebel gravatar imagestonedrebel ( 2019-04-21 17:55:55 -0600 )edit

I used sudo dnf system-upgrade download --allowerasing --releasever=29 but it didn't help and I'm still getting the same output.

TalGloz gravatar imageTalGloz ( 2019-04-22 01:06:53 -0600 )edit

Seems like some conflicts with the old drivers? Why don't you try and install fedora 29 from zero?

Jocsan gravatar imageJocsan ( 2019-04-22 01:57:00 -0600 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2019-04-22 04:12:13 -0600

TalGloz gravatar image

Well, removing the libicu62 package did the tick. I’ll have to install it and all the removed dependent packages after the upgrade.

edit flag offensive delete link more
0

answered 2019-04-22 03:52:54 -0600

villykruse gravatar image

The package libicu62-62.1-3.fc28.remi.x86_64 is not from the fedora repository, and to resolve the conflict you will need to remove that package.

You should probably also disable the repository where this packages came from and also remove any other packages coming from that repository.

edit flag offensive delete link more

Comments

Thanks, I found the way to upgrade. The remi repository was ported successfully.

TalGloz gravatar imageTalGloz ( 2019-04-22 04:14:03 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2019-04-21 16:57:12 -0600

Seen: 110 times

Last updated: Apr 22 '19