Ask Your Question
0

Gnome apps open in Wayland instead of remote SSH

asked 2019-04-18 14:21:05 -0600

Zan Lynx gravatar image

If I have an open Wayland session on a Fedora machine and then I try to SSH into that machine and run an app over the SSH X proxy, it doesn't work. It launches the app on the Wayland session which is locked and not useful to anyone at the moment because it is miles away at home.

Why does this happen?

Is there a way to fix this without forcing the open session to close using loginctl?

edit retag flag offensive close merge delete

Comments

Have you tried running Remmina on the remote end? If the remote is Fedora, it is a standard package.

wallyk gravatar imagewallyk ( 2019-04-18 14:45:26 -0600 )edit
1

Your remote machine is configured for running a wayland session and wayland is not network transparent. You can try forcing remote GUI applications to use X11. For gtk+ apps you set: GDK_BACKEND=x11 and for QT5 apps: QT_QPA_PLATFORM=xcb on the remote machine. I am not sure if you need a full X11 session on the client side. Will the GUI appear inside XWayland on the client? Just try.

fcomida gravatar imagefcomida ( 2019-04-18 15:38:17 -0600 )edit

@fcomida Well from my point of view the Gnome apps are buggy. How are they even determining they should run in Wayland? WAYLAND_DISPLAY is not set, neither are any XDG variables. As best I can tell they are abusing systemd user session which is ENTIRELY WRONG.

Zan Lynx gravatar imageZan Lynx ( 2019-04-19 16:44:40 -0600 )edit

@Zan Lynx create a new user in the remote machine and ssh to that user account. Try logging in your local machine from a VT (Ctrl+Alt+F3), same user as the running graphical session, run a GUI app from there and see what happens.

fcomida gravatar imagefcomida ( 2019-04-19 20:07:11 -0600 )edit

I just tried to reproduce it and something extrem wired happend: I logged into a f29 sshd with a running wayland session with "ssh -Y user@" and all cli cmds are run locally, but the start of firefox gets redirected to my local machine, and nemo window gets opened on the remote server. Both is clearly not what to expect and entirely wrong. I will take this to bugzilla on my own.

rdtcustomercare gravatar imagerdtcustomercare ( 2019-04-20 03:28:49 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-04-21 20:18:16 -0600

richard378 gravatar image

Wayland is bad for remote sessions. It just does not work. On your login screen click on the gear and choose xorg session for all remote sessions.

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2019-04-18 14:21:05 -0600

Seen: 257 times

Last updated: Apr 21 '19