Ask Your Question
3

Fedora 29 - Extremely slow, freezing... impossible to use

asked 2019-04-18 10:38:00 -0600

spCl gravatar image

Hello!

I've installed Fedora 29 Plasma KDE recently but it's been difficult to use it because it freezes many times if I do things like... navigating in internet.

In fact, my computer was very quick with Windows, but I decided to migrate to Linux instead of using VirtualBox.

So... the install was okay, so now I have 3 different partitions. One with Windows, another with Linux, and I had another partition with docs, photos etc, that could be accessed by both OS.

Detail, I opted for encryption during Fedora's install.

So... after everything was installed and later updated, everything is very, but really very slow. When I turn on my computer and choose to log in in Fedora, it takes around 5 minutes or more to charge everything. With Windows, before installing Linux in the same machine, the complete boot took less than a minute, but now Windows also takes a little bit more time, like 1 minute or something. Which is okay, comparing to +5 minutes.

So, about using Fedora, what is bothering me is that if I try to navigate in internet with Firefox, for example, if I open some few tabs, the system freezes completely, I can't do anything else, I need to turn off the computer and I'm afraid of doing that abruptly. Or if I started exploring the system and installed software, soon after the system freezes, too.

I don't think the problem is with my laptop's configurations because while using only Windows, I was able to have 30 or more tabs open in Firefox without any problem of performance and I never had to worry about internal fans because even with photo editors opened, I never really noticed the existence of fans. I mean, for my use, my CPU never reached high temperatures or freeze.

But using Fedora it does since when I open it. So I don't know if that's something normal with this OS, or if it's because I installed two OS in the computer, or maybe the encryption thing.

I would like to have my dev environment ready to work, but it's not possible to work if the system freezes all the time.

Could you please tell me if that's something normal when using Fedora or help me to discover where is the problem, if maybe my laptop is too weak for it or if I miss something?

(my laptop: Intel Core i7-65000u, up to 3.1Ghz, 6 GB memory, HDD 500G-128G(SSD))

edit retag flag offensive close merge delete

Comments

How does a Live System from USB perform?

florian gravatar imageflorian ( 2019-04-18 11:56:24 -0600 )edit

why...do you think that..florian. If it is not the wrong answer, I would like you to receive various opinions.

simmon gravatar imagesimmon ( 2019-04-18 11:59:36 -0600 )edit

It might be a KDE thing... I've heard people complain about KDE freezes, although I've never really used one actually. You can try other DE's (you don't have to re-install just sudo dnf groupinstall '<de name="">' and select different DE on log-in) for a quick fix, if you just want to get things done quickly. As for it being a normal behavior, no, linux distributions shouldn't take more resource than Windows, and dual booting shouldn't affect you very much...

skhds gravatar imageskhds ( 2019-04-18 23:13:30 -0600 )edit

yeah..I know kde..some bug...but it's a show another problem. i am kde F29/F30 user...and understand some bug and freezing.. but it's a need to find a solution for accept various opinion....

simmon gravatar imagesimmon ( 2019-04-19 01:51:41 -0600 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2019-04-20 00:57:54 -0600

florian gravatar image

Something is definitely wrong with your system, it may be a bug or some misconfiguration but we certainly need more information to help you troubleshoot your system. I have to say that I am not familiar with KDE. However, let's try to do some basic troubleshooting here.

0a.) Does your system behave like that no matter what kernel you boot. Sometimes there is a kernel regression and the newest kernel won't behave as expected. Try to boot an older kernel from grub and see what happens.

0b.) Is your system up-to-date? Run sudo dnf upgrade -y --refresh to get the latest updates.

1.) You say it takes long to boot your computer and load your user profile. For that, run the following commands from a command line to check what is actually taking so long: systemd-analyze critical-chain and systemd-analyze blame

2.) Also, make sure you have enough RAM available: free -h

3.) If you suspect that your CPU is under too much load, run htop and find out what processes are keeping it busy.

4.) Finally, check that your (root) file system has enough space for system to work: df -h

If all this does not point to anything suspicious, take a look at the system logs: journalctl -b, and kernel-related messages journalctl -k -b. There is also dmesg: dmesg | grep failed could be useful.

Check all this and get back to us! If you want you can install another Desktop Environment on top of your Fedora system and see how that turns out. (https://docs.fedoraproject.org/en-US/...)

edit flag offensive delete link more
-2

answered 2019-04-18 11:31:09 -0600

updated 2019-04-20 02:03:55 -0600

@spCl have a nice day!!

In situations where I suspect complex bugs such as encryption-related delays and preferences, I said that a normal installation without encryption is preferable. Reinstallation seems to be more desirable than solving time - consuming problems of various problems during the encryption process.

@florian...why reinstall to crypto system that reason.

It is not advisable to revert a disk that is already encrypted to an unencrypted state, and I have assumed that the encryption settings are not known in some way by the interrogator.

I do not think that it is easy to solve the problem of the encryption process and the problem of the system complicatedly, and the problems related to the actual operation and the like are intertwined.

Therefore, it is more desirable to solve the problem by reinstalling it compared to the time and efforts to solve the problem.

If you are not comfortable with similar symptoms, please re-install and use the system without encrypting the system during installation process. If the security issue is not particularly important, it select to install without selecting a cryptographic system configuration.

Depending on the type of encryption and the user's preference, system degradation may result. It is not advisable to compare Windows systems to running encrypted systems. Consider the benefits of a cryptographic system, but in this case you should also consider the fact that it can affect speed or the system.

If the server system is high-performance, you can expect a slight reduction in performance, but the performance of the encryption system on the single CPU is likely to be greater.

The F29 works really well and shows great performance in very low environments such as dual-core.

edit flag offensive delete link more

Comments

@simmon: in response to your comment above. I down-voted because I personally think you are not suggesting the right thing. Reinstalling is a bit excessive before recommending troubleshooting the problem. Also, did you see the specs of his machine? Why would encryption slow down the DE? Why are you talking about server systems when OP is clearly asking about a workstation environment with KDE. Overall, your answer is just not useful- that’s why I down-voted. Please don’t take it personal!

florian gravatar imageflorian ( 2019-04-19 01:23:35 -0600 )edit

it's reason...crypto system..single cpu.. crypto system complex to produce system. i show that reason system benefit or slow system. I'm normally use dual cpu system in my server. did you have a experience to crypto system in Fedora...? it's a already setup in crypto system in F29.. i recommend to reinstall method..more fast solve the problem.

simmon gravatar imagesimmon ( 2019-04-19 01:34:50 -0600 )edit

i7-6500u... Dual Core, 4 Threads. Certainly, a LUKS encrypted root partition is not the problem here. I’ve installed Fedora with LUKS/cryptsetup on way older machines, no problem at all.

Can’t follow your arguments.

florian gravatar imageflorian ( 2019-04-19 22:42:04 -0600 )edit

The settings may differ from your configuration, and the environment in which you are experiencing may be different from yours. I also do not accept your comments.

simmon gravatar imagesimmon ( 2019-04-19 23:05:46 -0600 )edit

You are not offering an evidence based solution, that's why I think your answer is -1

florian gravatar imageflorian ( 2019-04-20 00:47:24 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2019-04-18 10:38:00 -0600

Seen: 526 times

Last updated: Apr 20 '19