Ask Your Question

Fedora 29 suspend and resume closes all programs

asked 2019-04-12 02:58:33 -0500

fuzzybatman gravatar image

Running Fedora 29 on Dell XPS 15 9560 (16 GB RAM). Nvidia drivers installed from the negativo17 repo.

I have multiple workspaces with many programs open. When I suspend the laptop and resume, the gnome session launches (wallpaper is visible) and the system resets to the login screen immediately. I log in again and all of my programs are closed.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2019-04-12 17:23:18 -0500

fuzzybatman gravatar image

The problem seems to be with Gnome. Tried with KDE Plasma and works fine. journalctl -b has logs showing that gnome exited with code 1.

So wrong forum.

edit flag offensive delete link more


The problem can also be with NVidia drivers AND Gnome, not Gnome itself. If you can and are willing to test, try reproducing it using Intel's gpu -- preferably with disabled NVidia's gpu. Again, if you laptop allows it. Dell XPS should allow such configuration, I think (but don't know for sure).

Basically it looks like gnome session is crashing when you resume.

Night Romantic gravatar imageNight Romantic ( 2019-04-16 04:57:53 -0500 )edit

answered 2019-04-23 13:55:58 -0500

updated 2019-04-24 01:50:42 -0500

I'm experiencing same issue with Fedora 29 & GNOME on a Xiaomi Notebook Air 12.5. Actually, I've created a question here couple days ago, but I can't find it. Looks like it didn't pass moderation for some reason.

Xiaomi Notebook Air 12.5 runs on Intel video chip, so it doesn't look to be connected to NVidia drivers.

I confirm GNOME session is dropped when machine resumes from sleep. Here's a piece of result of systemctl command (init.scope section):

session-15.scope                    loaded active running   Session 15 of user gotterbild                                                
session-2.scope                     loaded active abandoned Session 2 of user gotterbild

Session #2 is abandoned and new session was started instead. Looks like I've locked screen for ~15 times since I have Session #15

edit flag offensive delete link more


Pavel Dolgov gravatar imagePavel Dolgov ( 2019-04-23 13:56:21 -0500 )edit

There was a similar issue with Fedora 21:

However, when I check /etc/default/grub, I have resume parameter in place with my swap drive's UUID.

Pavel Dolgov gravatar imagePavel Dolgov ( 2019-04-23 13:59:12 -0500 )edit

Here's the same bug that should have been closed in Fedora 28:

Pavel Dolgov gravatar imagePavel Dolgov ( 2019-04-24 01:53:39 -0500 )edit

Question Tools

1 follower


Asked: 2019-04-12 02:58:33 -0500

Seen: 174 times

Last updated: Apr 24 '19