Ask Your Question
0

dnf check-update failed

asked 2019-04-08 04:24:04 -0600

boycottsystemd gravatar image
    $ dnf check-update
...
Traceback (most recent call last):
  File "/bin/dnf", line 58, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.7/site-packages/dnf/cli/main.py", line 192, in user_main
    errcode = main(args)
  File "/usr/lib/python3.7/site-packages/dnf/cli/main.py", line 64, in main
    return _main(base, args, cli_class, option_parser_class)
  File "/usr/lib/python3.7/site-packages/dnf/cli/main.py", line 99, in _main
    return cli_run(cli, base)
  File "/usr/lib/python3.7/site-packages/dnf/cli/main.py", line 115, in cli_run
    cli.run()
  File "/usr/lib/python3.7/site-packages/dnf/cli/cli.py", line 1128, in run
    return self.command.run()
  File "/usr/lib/python3.7/site-packages/dnf/cli/commands/__init__.py", line 288, in run
    changelogs=self.opts.changelogs)
  File "/usr/lib/python3.7/site-packages/dnf/cli/cli.py", line 325, in check_updates
    columns = _list_cmd_calc_columns(self.output, ypl)
  File "/usr/lib/python3.7/site-packages/dnf/cli/cli.py", line 113, in _list_cmd_calc_columns
    _add_pkg_simple_list_lens(data, opkg, indent=" " * 4)
  File "/usr/lib/python3.7/site-packages/dnf/cli/cli.py", line 97, in _add_pkg_simple_list_lens
    rid = len(pkg._from_repo)
  File "/usr/lib/python3.7/site-packages/dnf/package.py", line 84, in _from_repo
    pkgrepo = self.base.history.repo(self)
  File "/usr/lib/python3.7/site-packages/dnf/db/history.py", line 368, in repo
    return self.swdb.getRPMRepo(str(pkg))
  File "/usr/lib64/python3.7/site-packages/libdnf/transaction.py", line 791, in getRPMRepo
    return _transaction.Swdb_getRPMRepo(self, nevra)
RuntimeError: Statement: attempt to write a readonly database in

        SELECT
            repo.repoid as repoid
        FROM
            trans_item ti
        JOIN
            rpm USING (item_id)
        JOIN
            repo ON ti.repo_id == repo.id
        WHERE
            ti.action not in (3, 5, 7, 10)
            AND rpm.name = ?
            AND rpm.epoch = ?
            AND rpm.version = ?
            AND rpm.release = ?
            AND rpm.arch = ?
        ORDER BY
            ti.id DESC
        LIMIT 1;

Any idea pls what to do ?

$ uname -a
Linux fedora 4.20.14-200.fc29.x86_64
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2019-04-08 09:42:51 -0600

fcomida gravatar image

See 1640235

edit flag offensive delete link more

Comments

Thank you.

boycottsystemd gravatar imageboycottsystemd ( 2019-04-08 12:07:17 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2019-04-08 04:24:04 -0600

Seen: 157 times

Last updated: Apr 08 '19