Ask Your Question
0

F29: dnf upgrade does nothing

asked 2019-04-03 06:59:25 -0600

boycottsystemd gravatar image

updated 2019-04-03 07:00:04 -0600

Although

dnf updateinfo list

says there are updates available. Any idea pls ?

edit retag flag offensive close merge delete

Comments

How about posting the output if any of

dnf upgrade

Maybe there are no updates currently. When was the last time you checked and did it work?

stonedrebel gravatar imagestonedrebel ( 2019-04-04 13:42:00 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2019-04-03 08:54:36 -0600

Night Romantic gravatar image

updated 2019-04-03 08:55:58 -0600

As far as I know,

sudo dnf check-update

will list actual packages that can be updated. At least, that's how I do it every day ;-)

man dnf says about dnf updateinfo:

Display information about update advisories.

updateinfo --list specifically prints the list of advisories. So no actual packages here.

edit flag offensive delete link more

Comments

link text <availability> specifies whether advisories about newer versions of installed packages (omitted or --available), advisories about equal and older versions of installed packages (--installed), advisories about newer versions of those installed packages for which a newer version is available (--updates) or advisories about any versions of installed packages (--all) are taken into account.

I'm using it for getting list of available security udates.

dnf upgrade

run successfully after 3 calls of it.

boycottsystemd gravatar imageboycottsystemd ( 2019-04-08 04:16:51 -0600 )edit

You're confusing list of advisories with list of available package updates. I tried to say it in my answer, but maybe wasn't clear enough. Advisory is some statement or posting (i.e. a text message) about found/fixed vulnerabilities or bugs. For example look at sudo dnf updateinfo --all info FEDORA-2019-f31c14682f. This advisory reads: "This update addresses various overflow conditions that could result in possible memory read/write out of bounds errors or zero byte allocations when connected to a malicious server." It also lists vulnerabilities fixed (for libssh2). That's the advisory.

Night Romantic gravatar imageNight Romantic ( 2019-04-09 03:22:59 -0600 )edit

Moreover, that's the advisory for package that was already updated.

Use sudo dnf check-update form the list of updates that you can actually apply right now.

Use sudo dnf check-update --refresh to force dnf to update it's database (i.e. to get new list of updates available).

Night Romantic gravatar imageNight Romantic ( 2019-04-09 03:25:24 -0600 )edit
0

answered 2019-04-08 04:19:05 -0600

boycottsystemd gravatar image
dnf upgrade

run successfully after 3 calls of dnf upgrade

So it looks like bug.

edit flag offensive delete link more

Comments

that's not what you asked. you can also run dnf -v upgrade to see more information on what it's doing in the background.

florian gravatar imageflorian ( 2019-04-08 10:12:31 -0600 )edit
1

Also, you can use sudo dnf check-update --refresh or sudo dnf upgrade --refresh to force the refresh of cached packages information.

Dnf uses it's cache by default, and doesn't refresh it every time you call for dnf. That's not a bug, that's intended behavior.

Night Romantic gravatar imageNight Romantic ( 2019-04-09 03:10:26 -0600 )edit

Also, age of cache is defined in the .repo files in /etc/yum.repos.d/

florian gravatar imageflorian ( 2019-04-09 22:08:02 -0600 )edit

Question Tools

2 followers

Stats

Asked: 2019-04-03 06:59:25 -0600

Seen: 111 times

Last updated: Apr 08 '19