Ask Your Question
0

Firewall-cmd not adding HTTPs as a service

asked 2019-04-02 16:46:25 -0500

Hi all, beginner Fedora user here. I'm currently attempting to set up HTTPS on a Node/Express server I'm running, and I'm attempting to open port 433 to the public, which involves opening the firewall on this port. I ran the following commands:

firewall-cmd --permanent --add-service=https
firewall-cmd --complete-reload
firewall-cmd --list-all

Only to see:

services: ssh dhcpv6-client cockpit http

which is obviously devoid of "https". Where could I possibly be going wrong, or am I missing some context?

Some technical details that may matter:

  • I'm using Fedora 28
  • This IP is running off a school network, so maybe things aren't forwarding to HTTPs (? I don't even know if that even makes sense tbh)

Thanks in advance!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-04-02 18:13:44 -0500

sideburns gravatar image

Welcome to ask.fedora! At first, this looked puzzling, but then I read the man page for firewall-cmd (man firewall-cmd) and found this:

The permanent option --permanent can be used to set options
 permanently. These changes are not effective immediately, only
 after service restart/reload or system reboot.

If you haven't done so already, try restarting the firewald daemon.

edit flag offensive delete link more

Comments

I usually use two commands in a row: with --permanent (if I need it) to make the change permanent, and without to apply change immediately without restarting firewalld.

Night Romantic gravatar imageNight Romantic ( 2019-04-03 09:04:50 -0500 )edit

Question Tools

2 followers

Stats

Asked: 2019-04-02 16:46:25 -0500

Seen: 31 times

Last updated: Apr 02 '19