python-sqlobject-1.2.2-3.el7.noarch shipped with EPEL 7 not compatible with PyGreSQL-5.0.6-1.rhel7.x86_64 from PostgreSQL 9.6

asked 2019-04-01 11:28:38 -0600

The python-sqlobject RPM requires "postgresql-python" meta RPM, which was provided by PyGreSQL:4.0-9 (from CentOS 7 repo) and PyGreSQL:5.0.3-1 (from PostgreSQL 9.6 Yum repo) as a migration path. Now PostgreSQL updated their repo with PyGreSQL:5.0.6-1, which does provide the newer "python2-PyGreSQL = 5.0.6-1", but not the "postgresql-python" meta RPM anymore. A dependency resolution fails.

Steps to Reproduce: 1. install PostgreSQL 9.6 repo: yum install https://download.postgresql.org/pub/r... 2. yum install PyGreSQL 3. yum install python-sqlobject

Actual results: Loaded plugins: etckeeper, fastestmirror, priorities Loading mirror speeds from cached hostfile 17 packages excluded due to repository priority protections Resolving Dependencies --> Running transaction check ---> Package python-sqlobject.noarch 0:1.2.2-3.el7 will be installed --> Processing Dependency: postgresql-python for package: python-sqlobject-1.2.2-3.el7.noarch --> Finished Dependency Resolution Error: Package: python-sqlobject-1.2.2-3.el7.noarch (epel) Requires: postgresql-python Available: PyGreSQL-4.0-9.el7.x86_64 (base) postgresql-python = 8.5.0-1 Available: PyGreSQL-5.0.3-1.rhel7.x86_64 (pgdg96) postgresql-python = 8.5.0-1 Installed: PyGreSQL-5.0.6-1.rhel7.x86_64 (@pgdg96) Not found You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest

Expected results: A successful installation.

Additional info: Newer upstream version of python2-sqlobject (note the "2") require "python2-PyGreSQL" directly (e.g. on Fedora). But this RPM is not contained in EPEL. Would it be a possible solution to include it?

I have created a bug report: https://bugzilla.redhat.com/show_bug..... What can I do to trigger processing?

edit retag flag offensive close merge delete

Comments

You have already filed a bugzilla report, and that is all you can do, unless you become a maintainer and fix it yourself. Give it time.

villykruse gravatar imagevillykruse ( 2019-04-01 14:26:46 -0600 )edit

Thanks for your quick answer. I understand the fact, but the thing is, that it is affecting all of our dev systems and the only workaround is to exclude PyGreSQL from the update, which is not what we want. Furthermore the bug report is now 4 months old and not even touched. I cannot imagine, we are the only affected, as EPEL and the PostgreSQL repo are truly not uncommon for PostgreSQL development.

martinvh gravatar imagemartinvh ( 2019-04-02 03:40:37 -0600 )edit

EPEL isnt Fedora. Most Fedora maintainers may not even maintain their packages in EPEL. EPEL has its own support channels where you may have more luck. I am afraid this forum is very much limited to Fedora users and volunteers.

FranciscoD_ gravatar imageFranciscoD_ ( 2019-04-03 02:14:13 -0600 )edit

Please correct me, EPEL is described as a Fedora Special Interest Group. The EPEL wiki states, that EPEL packages come from the Fedora repo (see here). The only poor thing is, that they list bugzilla to report bugs, which is what I have done already.

martinvh gravatar imagemartinvh ( 2019-04-03 06:23:39 -0600 )edit

It's a Special Interest Group in the sense that Fedora package maintainers may choose to also make their packages available for EL. In a lot of cases, a package will have different maintainers for Fedora and EPEL.

You've interepreted that statement incorrectly. EPEL packages are DERIVED from Fedora packages. That does not mean that Fedora packages are being used as is in EPEL---they usually cannot be used since Fedora and EPEL follow very different life cycles.

FranciscoD_ gravatar imageFranciscoD_ ( 2019-04-03 09:13:39 -0600 )edit