Ask Your Question
0

Having issue in updating fedora conflicting requests error.

asked 2019-04-01 00:39:11 -0600

[root@localhost kvy]# dnf update --skip-broken Last metadata expiration check: 0:03:09 ago on Monday 01 April 2019 10:00:19 AM IST. Error: Problem: package kernel-modules-extra-4.20.13-200.fc29.x86_64 requires kernel-uname-r = 4.20.13-200.fc29.x86_64, but none of the providers can be installed - conflicting requests

[root@localhost kvy]# dnf install kernel-modules-extra-4.20.13-200.fc29.x86_64 Last metadata expiration check: 0:09:31 ago on Monday 01 April 2019 10:00:19 AM IST. Package kernel-modules-extra-4.20.13-200.fc29.x86_64 is already installed. Dependencies resolved. Nothing to do. Complete!

[root@localhost kvy]# dnf install kernel-4.20.13-200.fc29.x86_64 Last metadata expiration check: 0:12:09 ago on Monday 01 April 2019 10:00:19 AM IST. Package kernel-4.20.13-200.fc29.x86_64 is already installed. Dependencies resolved. Nothing to do. Complete!

[root@localhost kvy]# dnf clean all 118 files removed

[root@localhost kvy]# dnf update Fedora Modular 29 - x86_64 78 kB/s | 1.5 MB 00:19
Fedora Modular 29 - x86_64 - Updates 39 kB/s | 2.1 MB 00:55
Fedora 29 - x86_64 - Updates 446 kB/s | 25 MB 00:56
Fedora 29 - x86_64 557 kB/s | 62 MB 01:54
RPM Fusion for Fedora 29 - Free - Updates 3.1 kB/s | 356 kB 01:55
RPM Fusion for Fedora 29 - Free 6.7 kB/s | 759 kB 01:53
RPM Fusion for Fedora 29 - Nonfree - Updates 4.6 kB/s | 87 kB 00:18
RPM Fusion for Fedora 29 - Nonfree 17 kB/s | 221 kB 00:12
Visual Studio Code 243 kB/s | 2.1 MB 00:08
Last metadata expiration check: 0:00:01 ago on Monday 01 April 2019 10:25:07 AM IST. Error: Problem: package kernel-modules-extra-4.20.13-200.fc29.x86_64 requires kernel-uname-r = 4.20.13-200.fc29.x86_64, but none of the providers can be installed - conflicting requests (try to add '--skip-broken' to skip uninstallable packages)

[root@localhost kvy]# dnf update --skip-broken Last metadata expiration check: 0:00:34 ago on Monday 01 April 2019 10:25:07 AM IST. Error: Problem: package kernel-modules-extra-4.20.13-200.fc29.x86_64 requires kernel-uname-r = 4.20.13-200.fc29.x86_64, but none of the providers can be installed - conflicting requests

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-04-01 04:31:33 -0600

Please visit :

https://koji.fedoraproject.org/koji/b...

Download "kernel" "kernel-core" "kernel-modules" "kernel-modules-extra" and whatever other package you need ( i.e. devel & headers for nvidia via akmods ) to /root/

cd /root/
rpm -ivh --oldpackage kernel*rpm

you will see the same output which would come if you had used dnf. Afterwards please erase the problematic kernel.

rpm -e kernel-4.20.13-200.fc29.x86_64 kernel-core-4.20.13-200.fc29.x86_64 kernel-modules-4.20.13-200.fc29.x86_64

Should be fixed.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2019-04-01 00:39:11 -0600

Seen: 145 times

Last updated: Apr 01 '19