Ask Your Question
1

dnf upgrade to fedora 29 from fedora 28 fails, gdm session freezes after login

asked 2019-03-30 15:20:29 -0500

tmstaedt gravatar image

updated 2019-04-02 21:38:26 -0500

Followed https://fedoraproject.org/wiki/DNF_sy.... The installation went through ok, but after reboot, the system hangs while waiting for some init process to complete. I read something like nfs peers, a time counter appears. The fedora 28 kernel would not boot anymore either. I am on a DELL INSPIRON AIO 5477. Reinstalled fedora 28 on the pristine system, did dnf upgrade --refresh and fedora 28 boots fine.


Investigated some more and with the kind help of rdtcustomercare, found some links,which may be of interest: https://bugzilla.redhat.com/show_bug.... https://bugzilla.kernel.org/show_bug...., which points to an archlinux page:

https://wiki.archlinux.org/index.php/... which talks about "xorg freezes at startup"

edit retag flag offensive close merge delete

Comments

a screenshot would be nice. Next time use this, did not fail me since F15 :D

rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-29-$(uname -i)
dnf clean all;dnf upgrade;
dnf --allowerasing --releasever=29 --setopt=deltarpm=false distro-sync
rdtcustomercare gravatar imagerdtcustomercare ( 2019-03-30 16:16:42 -0500 )edit

Nope, did not Work, same problem. Added two links to screenshots, one with the 5.0 kernel started, the second with the rescue kernel.

https://documentcloud.adobe.com/link/...

https://documentcloud.adobe.com/link/...

tmstaedt gravatar imagetmstaedt ( 2019-03-31 11:46:26 -0500 )edit

No diagnosis possible here, sorry. please refer to : https://help.ubuntu.com/community/Gru... && https://www.askapache.com/linux/linux... for a debug boot. You should start one service after the other by hand. ( interactive mode )

rdtcustomercare gravatar imagerdtcustomercare ( 2019-03-31 15:10:47 -0500 )edit

and if i may add: DON'T POST SOMETHING ON THE ADOBE CLOUD. It's a dataprotection menace!

rdtcustomercare gravatar imagerdtcustomercare ( 2019-03-31 15:12:06 -0500 )edit

Just tried to install from a live USB flash drive. And installed successfully, but when I did the dnf upgrade, after I entered my password in the gnome logon screen, there would only come up a grey screen, could only press the off button. I noticed, the upgrade installs a new 5.0.xx Linux kernel.

Also, during the installation, anaconda did crash once.

tmstaedt gravatar imagetmstaedt ( 2019-03-31 16:08:04 -0500 )edit

4 Answers

Sort by » oldest newest most voted
0

answered 2019-04-09 10:44:02 -0500

tmstaedt gravatar image

Maybe of interest: https://bugzilla.redhat.com/show_bug....

See, see. Followed instructions at https://www.if-not-true-then-false.co... to disable the nouveau driver, but did not install the proprietary one from Nvidia - and the machine comes up normally, could do a dnf update, no problems.

edit flag offensive delete link more

Comments

wieso postest Du den Link eigentlich so oft ?

btw:

get to rpmfusion.org , follow instructions for theire repo and enter "sudo dnf install nvidia" . Everything will happen more or less automatic and nvidia will just work.

rdtcustomercare gravatar imagerdtcustomercare ( 2019-04-13 10:02:57 -0500 )edit
0

answered 2019-04-02 21:54:16 -0500

tmstaedt gravatar image

I don't know exactly anymore how I got to https://www.if-not-true-then-false.co..., but the instructions on that page fixed the problem with the latest fedora 29 update.

One last thing I had to do to get it work, was commenting the line in /usr/lib/udev/rules.d/61-gdm.rules

DRIVER==”nvidia”, RUN+=”/usr/libexec/gdm-disable-wayland”

edit flag offensive delete link more

Comments

Nvidia and wayland should work together. I have nvidia running and can use gnome with wayland, so.. that may be outdated.

rdtcustomercare gravatar imagerdtcustomercare ( 2019-04-03 17:17:54 -0500 )edit
0

answered 2019-04-02 22:23:23 -0500

tmstaedt gravatar image

Was my answer deleted somehow??

I don't know anymore how I got to the following: https://www.if-not-true-then-false.co... But the instructions there fixed it.

One last thing I needed to do was commenting out the rule in /usr/lib/udev/rules.d/61-gdm.rules regarding wayland

DRIVER=="nvidia", RUN+="/usr/libexec/gdm-disable-wayland"

See https://github.com/negativo17/nvidia-...

edit flag offensive delete link more

Comments

tmstaedt, I would strongly suggest using either negativo's driver, or the one from rpmfusion instead of nvidia's generic one. It's easier and cleaner -- with packages you can always remove without leaving some leftovers all over your system.

I've written some details about it in this question and this one. And negativo has detailed how-to on his site.

Night Romantic gravatar imageNight Romantic ( 2019-04-03 09:15:19 -0500 )edit

And another way to solve the problem would be to disable nvidia's graphic card alltogether and use Intel's integrated one -- if you all-in-one allows this. Intel graphics are known to be stable and work good on linux systems, and nvidia ones are widely known to have problems from time to time :)

These problems can be troubleshooted, and nouveau open-source driver works ok for most of the users most of the time -- but still it's a hurdle for unprepared users.

Night Romantic gravatar imageNight Romantic ( 2019-04-03 09:21:20 -0500 )edit

Question Tools

2 followers

Stats

Asked: 2019-03-30 15:20:29 -0500

Seen: 120 times

Last updated: Apr 09 '19