can't connect to home wifi network on new fedora 29 install

asked 2019-03-28 21:21:16 -0600

Hello and thank you in advance for any help. Here's the situation:

I am relatively new to linux... used and installed a few different distros over the past 6 months on different machines... had various challenges but have been able to figure most out with time spent searching and reading manuals.

On my laptop (T470) I recently switched from openSUSE tumbleweed (KDE) that was running great since January to leap (also KDE) but had a few issues and decided to try Fedora (29, GNOME). Running CentOS (7 GNOME) on my workstation. Running macOS on another laptop. Both the workstation and mac have had zero issues with wifi, neither have various phones and tablets. Internet connection is satellite at present... relatively slow but gets the job done.

I installed Fedora 29 from a LIVE install USB created with rufus on a windows machine at work. Install went great. Fedora seems super fast on the T470. Ran the initial dnf update (or upgrade?) after install and it was connected to the internet just fine.

The next day it could not connect to the internet. It can see my home network, with excellent signal strength but does not connect automatically (setting is for all users to connect automatically) and when I type the password for wifi it does not connect and then asks again for the password... this repeats indefinitely. All other devices in the house are fully functional on the network. I took the T470 to work and it connected flawlessly to the wifi there, but back at home afterwards it does not work... which makes me think it's not a network issue or a driver issue or a computer issue but something going on specifically between something in Fedora and my home network.

Any advice on how to track this down?

edit retag flag offensive close merge delete

Comments

It isn't clear from your post if you did this already, so: I'd start from the most basic thing: delete your home wifi connection and set it up again from zero.

If you can't delete it from Gnome Settings (can't check right now, have no wifi at work), you should be able to delete it from nm-connection-editor (open gnome-terminal, type nm-con, then press [Tab] -- it should autocomplete for you, then [Enter] to launch).

And after you've deleted your existing connection, connect once more as usual. See if this helps by any chance.

Night Romantic gravatar imageNight Romantic ( 2019-03-29 07:04:53 -0600 )edit

Thanks Night, I did go to gnome settings and hit the red "forget connection" button and try to start form scratch that way. No change. I am at work currently and wifi is working flawlessly here. But I will follow your suggestion when I get back to the home network.

daniel.mac gravatar imagedaniel.mac ( 2019-03-29 08:44:30 -0600 )edit

Did as you said; opened nm-connection-editor and deleted the network. Rebooted just in case, then tried connecting; same result as before. I found a few other threads with similar experiences so I'm go to see if anything from those works, but if anyone has more suggestions please feel free to chime in. Thanks

daniel.mac gravatar imagedaniel.mac ( 2019-03-29 20:57:24 -0600 )edit

interestingly, the live usb that I installed from has no trouble accessing the home network.

daniel.mac gravatar imagedaniel.mac ( 2019-03-29 21:12:19 -0600 )edit

I gave up on this... just installed centOS and it's working fine.

daniel.mac gravatar imagedaniel.mac ( 2019-03-30 10:21:03 -0600 )edit