Bumblebee - Cannot access secondary GPU - error: [XORG] (EE) No devices detected.

asked 2019-03-26 08:21:48 -0500

tavk gravatar image

I am having trouble getting Bumblebee with the nvidia proprietary driver to work on my new notebook. I followed this guide: https://docs.fedoraproject.org/en-US/...
And that has worked for me on other notebooks before. (using Gnome. this time I use KDE)

Attempt to run command on dGPU:

$ optirun echo ""
[   68.431478] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) No devices detected.

[   68.431531] [ERROR]Aborting because fallback start is disabled.

Bumblebee daemon status:

$ sudo systemctl status bumblebeed.service 
● bumblebeed.service - Bumblebee C Daemon
   Loaded: loaded (/usr/lib/systemd/system/bumblebeed.service; enabled; vendor preset: disabled)
   Active: active (running) since Fri 2019-03-08 21:45:31 CET; 1min 12s ago
 Main PID: 966 (bumblebeed)
    Tasks: 1 (limit: 4915)
   Memory: 2.8M
   CGroup: /system.slice/bumblebeed.service
           └─966 /usr/sbin/bumblebeed

Mar 08 21:45:35 localhost.localdomain bumblebeed[966]: [   16.464921] [INFO]/usr/sbin/bumblebeed 3.2.1 started
Mar 08 21:46:27 localhost.localdomain bumblebeed[966]: [   68.431286] [WARN][XORG] (WW) Warning, couldn't open module mouse
Mar 08 21:46:27 localhost.localdomain bumblebeed[966]: [   68.431409] [ERROR][XORG] (EE) No devices detected.
Mar 08 21:46:27 localhost.localdomain bumblebeed[966]: [   68.431414] [ERROR][XORG] (EE)
Mar 08 21:46:27 localhost.localdomain bumblebeed[966]: [   68.431418] [ERROR][XORG] (EE) no screens found(EE)
Mar 08 21:46:27 localhost.localdomain bumblebeed[966]: [   68.431422] [ERROR][XORG] (EE)
Mar 08 21:46:27 localhost.localdomain bumblebeed[966]: [   68.431426] [ERROR][XORG] (EE) Please also check the log file at "/var/log/Xorg.8.log" for additional information.
Mar 08 21:46:27 localhost.localdomain bumblebeed[966]: [   68.431430] [ERROR][XORG] (EE)
Mar 08 21:46:27 localhost.localdomain bumblebeed[966]: [   68.431433] [ERROR][XORG] (EE) Server terminated with error (1). Closing log file.
Mar 08 21:46:27 localhost.localdomain bumblebeed[966]: [   68.431437] [ERROR]X did not start properly

GPU / Driver info:

$ lspci -k | grep -EA3 'VGA|3D|Display'
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 5600 (rev 0a)
        DeviceName:  Onboard IGD
        Subsystem: Gigabyte Technology Co., Ltd Device b556
        Kernel driver in use: i915
--
01:00.0 3D controller: NVIDIA Corporation GM204M [GeForce GTX 980M] (rev a1)
        Subsystem: Gigabyte Technology Co., Ltd Device b556
        Kernel modules: nouveau
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 0c)

My kernel parameters:

$ cat /proc/cmdline
BOOT_IMAGE=/vmlinuz-4.18.16-300.fc29.x86_64 root=/dev/mapper/fedora-root ro rd.driver.pre=vfio-pci kvm.ignore_msrs=1 intel_iommu=on amd_iommu=on iommu=1 rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1 nouveau.modeset=0 resume=/dev/mapper/fedora-swap rd.lvm.lv=fedora/root rd.lvm.lv=fedora/swap rhgb quiet

I also tried the following in addition to the kernel parameters that I already set to dis block the nouveau driver.

sudo grep -qxsF 'blacklist nouveau' "/etc/modprobe.d/blacklist.conf" || echo "blacklist nouveau" | sudo tee -a "/etc/modprobe.d/blacklist.conf" > /dev/null
sudo ...
(more)
edit retag flag offensive close merge delete

Comments

What version of NVIDIA driver you installed? You'd probably need the 390xx series.

fcomida gravatar imagefcomida ( 2019-03-28 18:15:45 -0500 )edit

and whats written in the Xorg logfile ?

rdtcustomercare gravatar imagerdtcustomercare ( 2019-03-30 15:56:19 -0500 )edit

@fcomida I just followed the linked guide so I assume I have the latest driver. Why do you think I need an older driver on KDE than on Gnome? I'd really prefer going with the latest one because of all vulnerabilities they found recently. @rdtcustomercare Do I even have an Xorg logfile when I'm on Wayland?

tavk gravatar imagetavk ( 2019-04-01 03:40:21 -0500 )edit

you pasted "Mar 08 21:46:27 localhost.localdomain bumblebeed[966]: [ 68.431426] [ERROR][XORG] (EE) Please also check the log file at "/var/log/Xorg.8.log" for additional information." follow it :D

rdtcustomercare gravatar imagerdtcustomercare ( 2019-04-01 04:35:30 -0500 )edit