Ask Your Question
1

Fedora 29 server can not able start Gui environment after installation

asked 2019-03-24 23:21:55 -0600

Nirmaan gravatar image

I have just now booted up my pc with fedora server 29 and I am not able to start Gui environment only shell is appearing on screen how can I start Gui environment ?

edit retag flag offensive close merge delete

Comments

1

Excuse me for asking, were there any reason to install Fedora Server instead of Fedora Workstation? Anyway, a Google search for "fedora server gui" gives plenty of answers that might help you further.

villykruse gravatar imagevillykruse ( 2019-03-25 03:13:32 -0600 )edit

"dnf groupinstall @cinnamon" that should install all you need for a ui system. you may have to switch to it: "systemctl isolate graphical" . That should start X, lightdm & cinnamon . Remember: you may now have a ui system, but you are missing all the tools like firefox, software center etc. You have to install them too.

rdtcustomercare gravatar imagerdtcustomercare ( 2019-03-25 16:15:33 -0600 )edit

Yep. You have to add a GUI to your install as already mentioned. There are different desktops you can choose from apart from Cinnamon.

stonedrebel gravatar imagestonedrebel ( 2019-03-25 18:02:13 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2019-03-26 09:12:09 -0600

updated 2019-03-26 09:32:46 -0600

For general Server Configuration and use a terminal environment when using the Fedora server.

Use the fedora workstation if you want a generic graphical environment installed.

If you need a GUI environment, you can set it through the following settings. server also needs a GUI environment and install below;

A. xorg related programs

# dnf install xorg*

B. install programs like a GUI : Gnome, Cinamon, KDE, etc.

# dnf install @workstation-product-environment
# dnf install @cinnamon-desktop-environment
# dnf install @kde-desktop-environment

C. If you do not need a GUI switch to terminal status and reboot. you can return to the terminal environment with the following command:

 # systemctl set-default multi-user.target
 # reboot

D. Return graphical status and reboot.

 # systemctl set-default graphical.target
 # reboot
edit flag offensive delete link more

Comments

and why should he reboot ? enter "systemctl isolate graphical.target" and it will do that immediately.

rdtcustomercare gravatar imagerdtcustomercare ( 2019-03-30 16:11:52 -0600 )edit

it's a effect at reboot, and gui or terminal show in check for login status.

simmon gravatar imagesimmon ( 2019-03-30 21:02:02 -0600 )edit

Question Tools

Stats

Asked: 2019-03-24 23:21:55 -0600

Seen: 94 times

Last updated: Mar 26 '19