Ask Your Question
0

Fedora 29 unable to boot - not showing on the UEFI system

asked 2019-03-16 12:18:35 -0600

hsguimaraes gravatar image

updated 2019-03-18 07:26:07 -0600

I have only one 1TB HD, and I did as follows:

1) installed Windows from oficial ISO file, matching my computer built-in license, with basic configuration, keeping 230GB of non-alocated space to install Fedora. That means GPT and UEFI. Windows created 3 basic partitions: a) recovery; b) efi; c) windows-root. And it left 230GB free. 2) installed Fedora from Fedora-Media-Creator tool (burned into usb-stick), using the default configurations from the installer, which uses the free space left. Fedora created 2 partitions and used 1 from Windows' Instalation: a) boot (/boot); b) efi (/boot/efi); c) lvm-mapper (swap, root, home). 3) at the end of the process, my HD has 5 partitions: a) recovery-windows; b) efi-windows/linux; c) root-windows; d) boot-linux; e) root-linux-lvm.

The Fedora installer finishes with a 'succesful' message, asking me to reboot the system to use Fedora. After rebooting, the system goes straight to Windows Boot Loader, not showing any options. Entering BIOS, or trying to use the hotkey (F12) to select another boot manager is useless. There's no recognition of the Fedora bootloader wherever I look in the BIOS.

Note1: This only happens to Fedora 29. I had Ubuntu 18.04 and 18.10 alongside with Windows using the same method: install Windows first, linux after. Both on UEFI and with Secure Boot on. My UEFI system and BIOS recognized Ubuntu as soon as I had installed it. Btw, I had Windows/Fedora 26 and Windows/Fedora 27 (if I remember right) on the same hardware (I don't change hardware in 6 years), both installed in secure boot UEFI mode. This only happens to Fedora 29.

Note2.: booting the live-USB (the one which I had installed Fedora), I can check that the EFI partition (sda2) is alright. All the boot files from Windows and Fedora instalation are there.

Note3.: I tried using the 'efibootmgr -v' through the live-USB and the option to boot Fedora is there. Nevertheless I removed all the entrys (including Windows Boot Loader) and manually added the fedora one, keeping it alone. It didn't work either. After reboot, UEFI system just go straight to Windows and Fedora is missing again.

Does anyone have any tips so I can have Fedora 29 working alongisde with Windows 10? Or should I just go back to Ubuntu (oh God, no...)?

UPDATE: I installed Ubuntu and it seems to have a good EFI writer, since it was able to make an Ubuntu entry in the EFI boot order. In fact, Ubuntu installation goes smoothly with Windows 10. All I have to do is press F12 (my BIOS hotkey to select a boot manager) and select Ubuntu. I'm even able to enter BIOS and make Ubuntu boot manager boots first, making grub2 the default boot loader, where I can select Ubuntu or Windows. So I tried a 'cheat' to make Fedora works (unsuccessful) as follows:

1) removed all the partitions Ubuntu created, through the Fedora live-usb; 2) installed Fedora 29 again, with automatic settings (including ... (more)

edit retag flag offensive close merge delete

Comments

efibootmgr -v also show the boot order, What is it? efibootmgr -n xxxx selects the next boot using number xxxx. Does that work?

villykruse gravatar imagevillykruse ( 2019-03-16 15:05:16 -0600 )edit

Thank you, for the reply. I manually: a) deleted the boot order with efibootmgr -O; b) every entry with efibootmgr -b 000x (1 to 6, I think) -B, until running efibootmgr -v shows nothing; c) then I added fedora manually with efibootmgr -c -d sda -p 2 -L 'Fedora' -l '\EFI\fedora\shimx64.efi'. So when I ran efibootmgr -v again it showed one entry with Fedora, and boot order with fedora entry alone.

hsguimaraes gravatar imagehsguimaraes ( 2019-03-16 16:32:32 -0600 )edit

I just removed all the partitions of Fedora (sda5 /boot; sda6 mapper-lvm), keeping the windows' partitions intact (sda1 recovery; sda2 efi; sda3 reserved; sda4 windows_root). Then I mounted sda2 on /mnt using a live-usb with Fedora 29 instalation and deleted EFI/fedora (the entire folder) and EFI/Boot/fb*.efi (since those files were generated after fedora instalation). After that, I runned efibootmgr -b 000x -B until I got no entrys left. Then efibootmgr -O to remove boot order and the program returned: "No BootOrder is set; firmware will attempt recovery". Now I'm reinstalling Fedora.

hsguimaraes gravatar imagehsguimaraes ( 2019-03-16 18:05:10 -0600 )edit

After reinstalling Fedora, before restarting, I ran efibootmgr -v and that's what it returns: BootCurrent: 0000 Timeout: 0 seconds BootOrder: 0000 Boot0000* Fedora HD(2,GPT,d7394682-1a40-4729-b9f4-eaa125a9611e,0xfa000,0x32000)/File(\EFI\fedora\shimx64.efi)

hsguimaraes gravatar imagehsguimaraes ( 2019-03-16 18:15:15 -0600 )edit

After restart, the system goes straight to Windows. F12 (which is my bios hotkey to select boot manager) only shows Windows Boot Manager. Entering setup I can verify that the booting order doesn't recognize fedora or other generic boot from the hard disk, only Windows Boot Manager. Secure Boot is ONE, UEFI only, Quick Boot OFF. No matter the changes I do to these settings, nothing changes. I ran efibootmgr -v with the live-usb again and the result I'll post in the next comment.

hsguimaraes gravatar imagehsguimaraes ( 2019-03-16 18:36:56 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2019-03-17 01:47:03 -0600

villykruse gravatar image

As you seems you have a broken UEFI implementation that is allergic to linux you may need to cheat:

cp /boot/efi/EFI/Microsoft/Boot/bootmgfw.efi /boot/efi/EFI/Microsoft/Boot/windows.efi
cp /boot/efi/EFI/fedora/shimx64.efi /boot/efi/EFI/Microsoft/Boot/bootmgfw.efi

So when your computer is thinking it is booting windows it is really booting the shim loader which will then load grub.

You can also do this copy from windows, (I believe).

See also and read the section about "Hijack the Windows boot loader"

edit flag offensive delete link more

Comments

Well, that's not the case, entirely. As I said before, Ubuntu works fine alongside Windows with the same setup. I have this issue with Fedora 29 only. I appreciate your reply, and I've managed to 'cheat' Windows Boot Loader with your instructions. The problem is Windows 10 'fixes' this 'cheat' as soon I launch Windows again. I think I discovered the core issue. If we pay attention to the outcome of efibootmgr -v that I replied before, we see an "RC" right after Windows Boot Manager entry only. Fedora entry doesn't have "RC" attached to it. When I tested with Ubuntu, its entry had the "RC".

hsguimaraes gravatar imagehsguimaraes ( 2019-03-17 11:19:57 -0600 )edit

Maybe the RC there stands for some optional parameters that need to be passed to UEFI firmware to work. I don't know how Ubuntu does it, but when I install it, it creates a boot entry with the "RC" optional parameters and my UEFI firmware accepts it, showing it when I press the F12 shortcut or enter bios.

hsguimaraes gravatar imagehsguimaraes ( 2019-03-17 11:22:52 -0600 )edit

How about hijacking a working Ubuntu entry.

villykruse gravatar imagevillykruse ( 2019-03-17 14:54:29 -0600 )edit

Well, that seems better. In fact, I just installed Ubuntu thinking the same. Maybe installing it, then after it generates the boot entry in UEFI, I just remove the partitions of Ubuntu (not the EFI one), reinstall Fedora, than replace the Ubuntu efi file with fedora ones. Or just try to point the Ubuntu entry on UEFI to fedora shimx64.efi file in \EFI\fedora with efibootmgr -b 000x -l '\EFI\fedora\shimx64.efi'.

hsguimaraes gravatar imagehsguimaraes ( 2019-03-17 14:59:17 -0600 )edit

But I'll wait until Fedora fixes the sound bug too (see my bug report here)...

hsguimaraes gravatar imagehsguimaraes ( 2019-03-17 15:00:55 -0600 )edit
0

answered 2019-03-17 10:29:52 -0600

richard378 gravatar image

Are you using UEFI boot for the install media? There are two boot options on install media and those boot options decide what the boot type will install when the media installs Fedora. Also, is Windows Legacy boot or UEFI?

edit flag offensive delete link more

Comments

I use BIOS option "UEFI only" when booting anything. So when I install Fedora, it installs it using UEFI. So do Windows. Both are using UEFI mode, as you can see by the partition information I mentioned.

hsguimaraes gravatar imagehsguimaraes ( 2019-03-17 11:26:08 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2019-03-16 12:18:35 -0600

Seen: 941 times

Last updated: Mar 18 '19