Ask Your Question
1

dnf upgrade - conflicting requests

asked 2019-03-11 04:31:10 -0600

fedefe gravatar image

updated 2019-03-11 05:14:31 -0600

hhlp gravatar image

Error:

 Problem 1: package kernel-modules-extra-4.20.10-200.fc29.x86_64 requires kernel-uname-r = 4.20.10-200.fc29.x86_64, but none of the providers can be installed
  - conflicting requests
 Problem 2: package kernel-4.20.10-200.fc29.x86_64 requires kernel-core-uname-r = 4.20.10-200.fc29.x86_64, but none of the providers can be installed
  - conflicting requests
(try to add '--skip-broken' to skip uninstallable packages)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2019-03-11 09:15:43 -0600

villykruse gravatar image

There are no kernel packages for kernel version 4.20.10-200. You have to upgrade them to the latest version 4.20.14-200.

    dnf install kernel-core-4.20.14-200.fc29.x86_64 kernel-modules-extra-4.20.14-200.fc29.x86_64 kernel-modules-4.20.14-200.fc29.x86_64 kernel-4.20.14-200.fc29.x86_64

If something requires kernel-modules-extra-4.20.10-200.fc29.x86_64, you have to exclude the kernel packages from the update:

dnf --excludepkgs=kernel\* update
edit flag offensive delete link more

Question Tools

Stats

Asked: 2019-03-11 04:31:10 -0600

Seen: 872 times

Last updated: Mar 11 '19